×

Discussion Board

Results 1 to 3 of 3
  1. #1
    Regular Contributor
    Join Date
    Nov 2004
    Posts
    153

    Unhappy Playing a sound after Dialing

    Hi,

    I just want to play a sound after making a Call.

    It looks like this .....

    CMyClass:ial()
    {

    ....
    ........
    ..............
    .........................
    ..................................

    call.Dial(status,KNumber);

    if(status==KErrNone)
    {
    iPlayer->PlayL();
    }
    ................
    .......................
    .............................
    }

    I'm able to make a call but not able to play the sound.

    Rather i tried out this piece of code.

    CMyClass::Test()
    {
    iPlayer->Play();

    RTelServer server;

    server.Connect();
    ...........
    .................
    .......................
    }

    Even this one is not working


    Please Help me in this regard......

    Thanks in Advance.....................

  2. #2
    Nokia Developer Moderator
    Join Date
    Mar 2003
    Location
    Lempäälä/Finland
    Posts
    29,144
    which platform are you using (which SDK, & which target phone model) ?

    Also is there any oerror shown (error notes, or returned error codes in any callback functions ) ?

    yucca

  3. #3
    Regular Contributor
    Join Date
    Nov 2004
    Posts
    153
    Hi Yucca,

    I'm working on N6630.No error is shown and i'm able to dial the number without playing the sound and i haven't implemented anything in the callback functions.

    Also,i have intialized everything correctly i.e, creating the CMdaAudioPlayerUtility and etc etc...No problem with playing the sound as an seperate application.

    Thanks in Advance,

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •