×

Discussion Board

Results 1 to 4 of 4
  1. #1
    Registered User
    Join Date
    Mar 2005
    Posts
    2

    Application Icon in Series 60 phones

    Hi,
    Am developing on the Nokia 6260 ,but am unable to display the icon on the top left corner when the application is launched ,i get the default jigsaw icon,i have defined the icons properly in Jad file and also have ensured its of the proper format and size(png and 28*28),I can get the icon on the Phone main menu.I have tried various other options like naming the icon file as same as the Midlet etc .but couldnt get it working.Did anyone get it working.

    Thanks in expectation

  2. #2
    Regular Contributor
    Join Date
    Apr 2003
    Posts
    58

    Similar Problem with the 6620

    For this phone the proper icon size is 42x29, but other than that I was having the same problem. The icon appeared in the menu correctly but the top-left of the application showed the jig-saw icon.

    I finally corrected the problem by changing the icon path defined in the MIDlet-1 line of the Jad file to be fully qualified. For example:

    This did not work correctly:
    MIDlet-1: Foo, res/icon.png, com.Foo

    But this did work correctly:
    MIDlet-1: Foo, /res/icon.png, com.Foo

    Not sure if that will help you but give it a shot.

    -c

  3. #3
    Registered User
    Join Date
    Apr 2004
    Posts
    6

    Re: Similar Problem with the 6620

    Originally posted by colinlawrence
    For this phone the proper icon size is 42x29, but other than that I was having the same problem. The icon appeared in the menu correctly but the top-left of the application showed the jig-saw icon.

    I finally corrected the problem by changing the icon path defined in the MIDlet-1 line of the Jad file to be fully qualified. For example:

    This did not work correctly:
    MIDlet-1: Foo, res/icon.png, com.Foo

    But this did work correctly:
    MIDlet-1: Foo, /res/icon.png, com.Foo

    Not sure if that will help you but give it a shot.

    -c
    Thanks.

    I am not sure if you helped him/her, but you did for me.

  4. #4
    Registered User
    Join Date
    Mar 2003
    Posts
    7

    Thumbs up Re: Application Icon in Series 60 phones

    Thanks a lot, it helped me too!

    I still think this is a Nokia bug, as it shows up on the programs menu with the relative path!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×