×

Discussion Board

Results 1 to 3 of 3
  1. #1
    Registered User
    Join Date
    Apr 2005
    Posts
    4

    mmapi 1.0 vs mmapi 1.1

    Hi..i want to know if i have developed an application using the mmapi 1.1,can it be installed in the mmapi 1.0 supported nokia phones?

    Actually im developing a music composer for nokia phones with mmapi 1.1 supported and i need MIDIControl functions in order to produce good sounds for music composing..any suggestions or comments will be greatly appreciated..

    thanks..

    gary

  2. #2
    Registered User
    Join Date
    Jul 2003
    Posts
    26
    I think shortMidiEvent is part of JSR 135, so the phone must support that, and also not have any "known issues" as does the early 6600. Haven't got a later 6600 to try it on.

    I'm playing around with the API on a 6170 now, and hitting some strange quirks: using short midi events on MIDI channel 9 (drum sounds) only plays 44 drum sounds, then silence. I have tried to send a note off event (even though the MIDI spec says you do not need to), but that makes no difference. Have you experienced that too?

  3. #3
    Nokia Developer Expert
    Join Date
    Jul 2003
    Posts
    46
    MMAPI 1.1 is binary compatible with MMAPI 1.0. The differences are in the documentation, not in classes or methods.

    MMAPI 1.1 mainly enhances the locators you give in createPlayer.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×