×

Discussion Board

Results 1 to 2 of 2
  1. #1
    Registered User
    Join Date
    Mar 2003
    Posts
    2

    Could not create JVM

    Hi,

    In the 9210sdk emulator,when i run sample application it says..
    could not create the JVM .what could be the probable reason?

    If anybody has faced this problem and found the solution, pls share it

    thanx in advance

    Siva

  2. #2
    Registered User
    Join Date
    Mar 2003
    Posts
    2

    RE: Could not create JVM

    I had the exact same problem and spent half the day trying to get HelloWorld running. It was a great way to spend four hours.

    Here is what I learned:

    1) Running on Windows 2000 is fine.

    I was worried when I saw the "unsupported" message during the SDK installation, but now that it works, I realize that the platform wasn't an issue.

    2) I cannot run the java application directly from the command line.

    Example: > <your-SDK-path>\epoc32\release\wins\urel\pjava -cp j:\Hello\helloapp.jar Hello. The documentation has tons of instances of this and IT DOESN'T WORK. All that happens is you get the Emulator. If you try to run the application from Extra, you receive the "Cannot create java virtual machine" error.

    3) The emulator must load the application automatically.

    That means following the directions to create the necessary AIF files and correct directories. Make sure you set the output files to the right directory or it won't work. Once you do this, simply run the emulator by itself. In the Extra section, you should see the application, and it will run.

    4) You MUST install Perl.

    I didn't install Perl at first. When I tried running the AIF Builder, it said to check value the EPOCROOT and make sure the executable was accessible. This suggestion is completely useless. Once I installed Perl from the SDK setup, everything ran fine.

    Hope this helps,

    Jesse

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×