×

Discussion Board

Results 1 to 8 of 8
  1. #1
    Registered User
    Join Date
    Mar 2005
    Posts
    4

    Execution stops constantly in ntdll.dll

    When using the CodeWarrior 3.0 debugger, (and 2.8 too), the execution stops all the time in ntdll.dll. Take a look at this screenshot for possibly more information. What gives? It's highly annoying.

  2. #2
    Nokia Developer Expert
    Join Date
    Dec 2004
    Location
    Austin, TX
    Posts
    399
    In 3.0 release there's an "x86 Exceptions" target preference panel. First disable Access Violation. If you still get it then disable them all and selectivly add them back in to see which exception the debugger is halting on (though my guess is that it's an Access Violation.)

    Cheers,
    Tim

  3. #3
    Registered User
    Join Date
    Mar 2005
    Posts
    4
    Unfortunately none of them cured it.

  4. #4
    Nokia Developer Expert
    Join Date
    Dec 2004
    Location
    Austin, TX
    Posts
    399
    Assuming you disabled ALL the x86 Exceptions, I wonder what SDK you are using and if this happened this first time you installed the SDK or only after some time.

    Cheers,
    Tim

  5. #5
    Regular Contributor
    Join Date
    Oct 2004
    Location
    Tokyo,Japan
    Posts
    289

    Question Re: Execution stops constantly in ntdll.dll

    hi guys ,
    i am facing same problem as described above ,

    "the execution stops all the time in ntdll.dll. "


    so can any symbian/nokia expert tell me the root cause of this problem.


    thanks in advance.
    regards
    nEo

  6. #6
    Registered User
    Join Date
    Sep 2007
    Posts
    40

    Angry Re: Execution stops constantly in ntdll.dll

    I have the same problem.

  7. #7
    Registered User
    Join Date
    Oct 2007
    Posts
    5

    Re: Execution stops constantly in ntdll.dll

    Faced the same problem when porting C code to Symbian. Has anyone found a solution for this problem? I think it could be related to using POSIX pthreads...

    I'm using CodeWarrior 3.1 but I'm not sure if this a CW issue.

    For me it was this line
    Code:
    pthread_mutex_init((pthread_mutex_t *)handle->pObject, NULL)
    So this is an openC issue for me.. Any help?

    EDIT: The problem for me was actually the open c console popping explained here
    Last edited by kankatom; 2007-11-20 at 12:18.

  8. #8
    Regular Contributor
    Join Date
    Oct 2004
    Location
    Tokyo,Japan
    Posts
    289

    Thumbs up Re: Execution stops constantly in ntdll.dll

    hi
    i also experience this type of problem sometimes.
    i guess
    a) its due to some binary break.

    b) also , some times it occurs when you are using a dll made by one codewarrior version on the other version of codewarrior.

    c) may be also due to non-avalability of some dll at runtime.
    (perhaps ECOMs)

    i hope this may help you...

    cheers
    nEo

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×