×

Discussion Board

Results 1 to 3 of 3
  1. #1
    Registered User
    Join Date
    Mar 2005
    Posts
    2

    symbian "invalid version" Java

    I am using a nokia 6260 and must upload J2ME code to the phone.

    I get

    "Invalid version error"

    when I do "*#0000#" I get,

    V 3.0436.0
    03-09-04
    RM-25

    I think this refers to an older version of Symbian os (not 7.0)

    I susypect that the phone version is too old for the programs, is there a way I can upgrade the os of the phone?

  2. #2
    Super Contributor
    Join Date
    Mar 2003
    Location
    Finland
    Posts
    9,557
    The 6260 is based on Symbian OS 7.0s and Series 60 2.1 (Series 60 2nd Edition, Feature Pack 2).

    It supports MIDP 2.0 (JSR-118) & CLDC 1.0 (JSR-30).

    *#0000# shows the firmware version, its date and the phone Nokia model designation (RM-25 = 6260).

    What the "Invalid version error" means in this case, I don't know. Perhaps a MIDlet for CLDC 1.1?

  3. #3
    Regular Contributor
    Join Date
    Oct 2004
    Posts
    79
    When I try to upload midlet with MicroEdition-Profile: MIDP-1.0 via bluetooth on 6600, I also saw error "Invalid version error". With MicroEdition-Profile: MIDP-2.0 midlet was uploaded without problems.
    But it isn't matter what MicroEdition-Profile version was written in manifest, when I have uploaded midlet through WAP

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×