×

Discussion Board

Results 1 to 9 of 9
  1. #1
    Registered User
    Join Date
    Apr 2005
    Posts
    11

    SIP 415 Unsupported Media Type

    Hello,

    We are testing a SIP application in real enviroment.

    After registration, the caller phone sends an INVITE with content-type: text/xml. At this point, the other telephone outputs an error message: "415 Unsupported Media Type".

    We have created the sipappcapabilities.xml acording to the dtd.

    The sipappcababilities.xml, the lines SipClientInstaller.exe with parameters FR, RI, RW and the SipClientUnInstaller.exe with these parameters FR, RR, RW are included in the .pkg.

    Does anyone know where the problem can be? Is there any restriction concerning content-types?

    Thanks!!

  2. #2
    Registered User
    Join Date
    May 2003
    Posts
    187

    Unspported Media Type

    Hi,

    That happened with me , one thing you can do is browse for SipClientInstaller.exe, copy under your application directory and run it explicitly, I mean click on it and it will work.

  3. #3
    Registered User
    Join Date
    May 2005
    Posts
    38
    Hi Rami,

    but this is applicable for only SIP 2.0 as SIP 3.0 does not have SIPClientInstaller.exe file

    I am getting similar problem. Any idea , how I can resolve it ?

    Tom

  4. #4
    Registered User
    Join Date
    May 2003
    Posts
    187
    Hi Tom,

    I will have a look and let you know how it can be done for sip 3.0

  5. #5
    Registered User
    Join Date
    May 2005
    Posts
    38
    Thanks Rami..

    Tom

  6. #6
    Registered User
    Join Date
    May 2003
    Posts
    187
    Hi Tom,

    For SIP 3 I read the release notes that comes with SIP stack, which says that you should use SipClientInstaller.exe and SipClientUnInstaller.exe .
    ---------------------------------------------------------------------------------------
    - To create SIS installation file Use command "makesis chipflip.pkg". Succesful creation requires:
    Installed Symbian S60 SDK, for example version 2.0 or 2.1,
    Chipflip compiled on THUMB UREL plaform,
    file SipAppCapabilities.xml in folder Chipflip\group,
    files SipClientInstaller.exe and SipClientUnInstaller.exe in folder Epoc32\release\thumb\urel

    ---------------------------------------------------------------------------------------
    I'm still confused about that , If I found something I will write it down her

  7. #7
    Registered User
    Join Date
    May 2005
    Posts
    38
    Thanks Rami

    Tom

  8. #8
    Registered User
    Join Date
    Sep 2004
    Posts
    34
    hi, tom

    have you succeeded?
    please let me know

    wolftongren@msn.com

    thanks~

  9. #9
    Registered User
    Join Date
    Jan 2005
    Posts
    15
    The documentation concerning the .xml file is astonishinly poor. It's like they never even attempted to deal with outside SIP servers.

    Your .xml and sdp headers are used to make sure that both ends of the connection are compatible, and as such, they need to declare their capabilities (hence the name). You need to have something to the effect of:
    <SDP_LINES>
    <LINE name="m" value="audio 5020 RTP/AVP 3"/>
    <LINE name="a" value="rtpmap:3 GSM/8000"/>
    <LINE name="a" value="rtpmap:0 PCMU/8000"/>
    </SDP_LINES>
    in your .xml file. The GSM, and PCMU denote the codecs supported, so don't use them if you don't support these codecs. You'll also need to set up your sdp headers the same way. The best way to do this is to register with the SIP server emulator and check the log in order to make sure your sdp file is set up correctly.

    Our problem has been completing the invite from behind a firewall. The current sip solution does not cooperate with firewalls well...even so-called SIP enabled firewalls.

    Let me know how it turns out...especially to see if you can complete an invite from behind a firewall.

    Regards,
    -Ron

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×