×

Discussion Board

Results 1 to 5 of 5
  1. #1
    Registered User
    Join Date
    Feb 2005
    Posts
    9

    Deployment problem

    Hi
    I used Sun's J2ME WTK to build a simple HelloWorld application. The problem is that it compiles and works on teh emulator without any problems but when I transfer the application to the phone, the only option I have is to "delete" the application. I cant run it (the other options are greyed). Is this becuase of an authentication problem? that I didnt set the information about the developer and so on?

    Thanks in advance
    Janaka

  2. #2
    Registered User
    Join Date
    Nov 2004
    Posts
    6
    How did you install the jar in your phone? And what phone do you use?

  3. #3
    Registered User
    Join Date
    Feb 2005
    Posts
    9
    The phone is a Nokia 3200. I tried using the Nokia PC suite's option to install the application and Oxygen Phone Manager's options. The files were transfered via a DKU5 cable.

    (I have used Oxygen before to install applications on my phone and it worked. I do recall one instance however where the same problem was there for a graphical calculater software I downloaded. You might be able to find it in www.garret.ru/~knizhnik/mobile.html )

    Any idea why? The application was an example in the WTK guide (TinyMIDlet ).

  4. #4
    Registered User
    Join Date
    Nov 2004
    Posts
    6
    your phone supports CLDC 1.0 & MIDP 1.0. one possibility is that the midlet you downloaded might be of a later version. try to see if you can determine the CLDC and MIDP version of the midlet.

  5. #5
    Registered User
    Join Date
    Feb 2005
    Posts
    9

    Problem solved. Wrong WTK version :S

    Hi everybody

    I got the problem solved. Apparently I have been using the wrong version of the WTK. :S :$

    Thanks anyway for helping out

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •