×

Discussion Board

Results 1 to 4 of 4

Thread: ethernet plugin

  1. #1
    Regular Contributor
    Join Date
    Mar 2005
    Posts
    176

    ethernet plugin

    hy,

    i am trying to configurate ethernet on emulator for sdk 2nd fp 2 ... but when i am installing the plugin it doaesn't detects my sdk .(no sdk installed)... my sdk is not on my os partition ... i have it on other partition ...


    so any hints?



    thanks

  2. #2
    Regular Contributor
    Join Date
    Apr 2005
    Posts
    89
    Generally speaking fp2 have built-in network support (one of the installation options), but I was not able to get it working, neither built-in nor by installing everything I could find in the Internet, and neither could other people I asked. So I just use fp1 for testing, built-in network emulation works there (except for des16align errors from time to time). fp3 beta also works, but it's only for CodeWarrior for now.

  3. #3
    Regular Contributor
    Join Date
    Mar 2005
    Posts
    176

    what about 2nd fp1

    how did u configure this sdk?


    what steps did u follow


    thanks for support

  4. #4
    Regular Contributor
    Join Date
    Apr 2005
    Posts
    89
    Made sure Ethernet Support component is checked during the installation, then selected Start -> Programs -> Series 60 Developer Tools -> Series 60 C++ SDKs -> SDK 2.1 for Symbian OS Supporting Microsoft Visual C++ .NET -> Tools -> Ethernet Support Configuration, and specified a new IP-address (not one used by PC but free one) and my DNS server address. I use promiscous mode, although I don't know what does it mean. If your network configuration is different (you have DHCP, proxy, several adapters), your might need to specify some more (or less) settings, but I hope if you can debug TCP/IP programs you wouldn't get lost there.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×