×

Discussion Board

Results 1 to 8 of 8
  1. #1
    Registered User
    Join Date
    Sep 2003
    Posts
    14

    Exclamation Network connection not working on S60 2nd Ed FP2 emulator

    Has someone got the network connection working on the Series 60 2nd Edition FP2 emulator? I have successfully managed to get the connection working on previous SDKs (1st Edition, 2nd Edition with and without FP1). However, FP2 does not seem to want to co-operate.

    When I try to run any networked application such as the Services browser, it says "No gateway reply". However, when I use the npacketadmin it does show that packets have been sent and received.

    I have changed the Ethernet settings using the menu on the emu according to the network. I have disabled promiscuous mode because I am using a WLAN adapter that does not support it and set the IP, subnet mask, gateway and DNS addresses by hand. It has worked fine before with the same settings and I have tried it on two different networks.

    What is wrong? Please help. Not being able to debug networked applications on the emulator is really a problem. Thanks for any help!

  2. #2
    Registered User
    Join Date
    May 2005
    Posts
    25
    Are your have one network interface?
    If you have more then one network interface your must choose interface in prefencese window.

  3. #3
    Registered User
    Join Date
    Sep 2003
    Posts
    14
    Yes, I do have multiple NICs and I have selected the NIC accordingly. Actually, I have also tested on another network with both WLAN and LAN (the latter with promiscuous mode) and the emulator's network connection did not work there either.

  4. #4
    Registered User
    Join Date
    Jun 2004
    Posts
    17

  5. #5
    Registered User
    Join Date
    Sep 2003
    Posts
    14
    No, unfortunately Nierdre's suggestion did not work either. And for clarification I have already tried also the suggestion in the release notes by checking that the packet delivery service (or something similar) is started with the npacketadmin program.

  6. #6
    Registered User
    Join Date
    Sep 2003
    Posts
    14
    Now I got it working!

    The problem was apparently was that I did not have promiscuous mode enabled in the network settings. When promiscuous is disabled, it gives the same old error. Promiscuous cannot be enabled with my integrated WLAN (it does not support it), so I must use LAN.

  7. #7
    Registered User
    Join Date
    Jun 2005
    Posts
    1
    This is to add to the above finding.

    I have a Wireless adapter and a regular ethernet adapter. when starting up the emulator and attemptig to connect via ethernet with the WAN adapter selected i get a "No Gateway Reply" error. this is with the promiscuous mode selected or unselected and with a static ip.

    if i select the regular ethernet adapter and select promiscous then it works without a hitch.

    hope this helps someone.

  8. #8
    Registered User
    Join Date
    Apr 2006
    Posts
    5

    Smile Re: Network connection not working on S60 2nd Ed FP2 emulator

    In S60 2.ed FP2 Release Notes, you can find a way to manage the network services, which sometimes are not started correctly.

    I had a problem with my wireless NIC adapter, which does not accept promiscuous mode (in this mode, all the information passed through the NIC is sent to the computer), but i could set other modes (that replaced the promiscuous mode) this way: (it is also useful to connection problems on FP2)

    - In some environments Ethernet Support fails to initialize correctly.
    Workaround: Start npacket service manually. The detailed steps are as follows:
    -- Assumption: ethernet support is configured using configuration UI
    -- in Emulator -> Tools -> Preferences -> Ethernet Settings
    1. Start emulator
    2. Start Browser (or another application using TCP/IP)
    3. Start application called npacketadmin.exe from
    \<SDK_Installation>\Epoc32\tools
    4. From npacketadmin UI select the network adapter you are
    using for TCP/IP connectivity.
    5. Check the status. Correct state should be "STARTED", when emulator
    is running.
    6. If status is "STOPPED", close the emulator.
    7. After emulator has been shut down. Select "Start" button.
    8. When status has changed to "STARTED", restart emulator.
    9. Test that browser functions normally.

    On "npacketadmin" you can set your NIC modes. There are some to replace promiscuous mode
    Actually, it works better with LAN NIC adapters.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×