Discussion Board

Results 1 to 2 of 2
  1. #1
    Registered User
    Join Date
    Mar 2003

    i cannot run any java program in 9200 SDK

    hi! i cannot run even the examples which come with the SDK, the program says:
    Exception in thread "main" java.lang.NoClassDefFoundError: com/symbian/devnet/crystal/dicemachine/DiceMachine
    or any other program y run, from HelloWorld to PowerMonitor in the examples directory.
    i have tried to compile the programs with jdk 1.1.8 and 1.4 but same
    maybe i am missing some path or sth? cawt.jar is placed in the emulator and i have placed in different places just in case...
    or could it be because i have W2k?
    I would appreciate any hint you can give me...

  2. #2
    Registered User
    Join Date
    Mar 2003

    RE: i cannot run any java program in 9200 SDK

    I was tearing my hair of over the same problem and it was solved by changing JDK from 1.4 to 1.2.2. Make sure that JDK 1.2.2 is first in your path so that it is used to run the emulator.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts