×

Discussion Board

Page 4 of 4 FirstFirst 1234
Results 46 to 49 of 49
  1. #46
    Registered User
    Join Date
    May 2007
    Posts
    57

    play video/audio clips while talking in an active call

    Hi,
    Thank you for your reply.I sloved this using CDocumentHandler api but file is playing only at once even though
    i changed music player setting manually i.e repeat play-> on.
    do u know what should i do for this?
    Cheers...
    Sunil W.

  2. #47
    Registered User
    Join Date
    Feb 2010
    Location
    India
    Posts
    281

    Re: Play audio to uplink:: Solution

    Quote Originally Posted by symbianyucca View Post
    sometimes the past experiences doesn't really help... Anyway, have been working with this problem quite awhile and getting all sorts of answers from out & inside Nokia, anyway nobody really seems to have good answers, so, like I usually say, when you want to get it done fast, you gotta do your research by yourself.

    Anyway, it appers that audio playing to the uplink can be achieved pretty easily and without any extra capabilities. I was testing this with all 13 that do not need any scpecial approval (and would be great if somebody could test and narrow it down to the minimal required set). So first define capabilities in your mmp file:

    CAPABILITY NetworkServices LocalServices ReadUserData WriteUserData Location UserEnvironment PowerMgmt ReadDeviceData WriteDeviceData TrustedUI ProtServ SwEvent SurroundingsDD

    And then the trick is not to use normal Audio player or recorder, but to use CDrmPlayerUtility. And I was testing it like this:

    iMdaAudioPlayerUtility = CDrmPlayerUtility::NewFilePlayerL(iFileName.iName, *this,80,(TMdaPriorityPreference)0x00060001);

    and in init coplete just call Play() and it plays the audio nicely to the uplink.

    yucca
    Its not working for S60 5th edition.. can you help me how to do?

  3. #48
    Nokia Developer Moderator
    Join Date
    Mar 2003
    Location
    Lempäälä/Finland
    Posts
    29,165

    Re: Play audio to uplink:: Solution

    That workaround was based on a bug on the OS, and it has been fixed already. Thus try out APS or VAS.

  4. #49
    Registered User
    Join Date
    Feb 2010
    Location
    India
    Posts
    281

    Re: Play audio to uplink:: Solution

    Quote Originally Posted by symbianyucca View Post
    That workaround was based on a bug on the OS, and it has been fixed already. Thus try out APS or VAS.
    APS 2.4.3 is not supporting for S60 5th Edition. I want to uplink the audio during phone call

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×