×

Discussion Board

Results 1 to 2 of 2
  1. #1
    Registered User
    Join Date
    Jul 2005
    Posts
    4

    Unhappy SDK2 FP3 wins build problem - EDLL.LIB

    Hi,

    I recently installed s60_2nd_sdk_fp3 and I'm having problems building for a wins target.

    I'm trying to build the OpenGL ES example and using the command:

    Code:
      abld build wins udeb
    However, this fails with the following message:

    Code:
      make -r  -f "\Symbian\8.1a\S60_2nd_FP3\EPOC32\BUILD\GLEXAMPLE\GROUP\EXPORT.make" EXPORT VERBOSE=-s
    Nothing to do
      make -r  -f "\Symbian\8.1a\S60_2nd_FP3\EPOC32\BUILD\GLEXAMPLE\GROUP\WINS.make" MAKEFILE VERBOSE=-s
    perl -S makmake.pl  -D \GLEXAMPLE\GROUP\GLEXAMPLE   WINS
      make -r  -f "\Symbian\8.1a\S60_2nd_FP3\EPOC32\BUILD\GLEXAMPLE\GROUP\WINS.make" LIBRARY VERBOSE=-s
    nmake -nologo -x - -s  -f "\Symbian\8.1a\S60_2nd_FP3\EPOC32\BUILD\GLEXAMPLE\GROUP\GLEXAMPLE\WINS\GLEXAMPLE.WINS" LIBRARY
      make -r  -f "\Symbian\8.1a\S60_2nd_FP3\EPOC32\BUILD\GLEXAMPLE\GROUP\WINS.make" RESOURCE CFG=UDEB VERBOSE=-s
    nmake -nologo -x - -s  -f "\Symbian\8.1a\S60_2nd_FP3\EPOC32\BUILD\GLEXAMPLE\GROUP\GLEXAMPLE\WINS\GLEXAMPLE.WINS" RESOURCEUDEB
      make -r  -f "\Symbian\8.1a\S60_2nd_FP3\EPOC32\BUILD\GLEXAMPLE\GROUP\WINS.make" TARGET CFG=UDEB VERBOSE=-s
    make: *** [TARGETGLEXAMPLE] Error 2
    nmake -nologo -x - -s  -f "\Symbian\8.1a\S60_2nd_FP3\EPOC32\BUILD\GLEXAMPLE\GROUP\GLEXAMPLE\WINS\GLEXAMPLE.WINS" UDEB
    NMAKE : fatal error U1073: don't know how to make '"\Symbian\8.1a\S60_2nd_FP3\EPOC32\RELEASE\WINS\UDEB\EDLL.LIB"'
    Stop.
      make -r  -f "\Symbian\8.1a\S60_2nd_FP3\EPOC32\BUILD\GLEXAMPLE\GROUP\WINS.make" FINAL CFG=UDEB VERBOSE=-s
    Any suggestions as to the silly mistake I've made? Building for a device works OK (with armi anyway. I haven't tried thumb yet).


    --
    Mnem.

  2. #2
    Registered User
    Join Date
    Jul 2005
    Posts
    4
    Now that I actually pay attention to the directory contents, it seems that FP3 doesn't include a wins target.

    Is this no longer supported? Makes debugging a touch difficult if that's the case ;)



    --
    mnem

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×