×

Discussion Board

Results 1 to 4 of 4
  1. #1
    Registered User
    Join Date
    Sep 2004
    Posts
    31

    Beginners guide to SDKs

    Hi All,

    Can somebody be so kind as to tell me what I need to start developing for the NGAGE, I recently wrote a game for the XBOX in C++ and want to try my hand on some ngage stuff.

    Please start right at the beginning. I did search the forum but most of the responses to similar questions say things like " get ver 1.2 for symbian", which is difficult as it doesnt seem to exist anymore, (superceeded by 2nd ed of 1fp or somthing?!??"?)

    I have Windows XP sp2, and I want to write for NGAGE QD.

    what are the steps in between?

    1) Which IDE (Visual Studio 6 ok?)
    2) Which SDK (for the NGAGE and IDE chosen in question 1)
    3) Any other documents I might need.

    Any help would be great as I have tried a number of times, with different SDKs and IDEs but just get nowhere. If you could supply actual links to the IDE download page that would be ace!

    Many Thanks and sorry for being a cheeky git!
    Jamie Fuller

  2. #2
    Super Contributor
    Join Date
    Mar 2003
    Location
    Finland
    Posts
    9,569
    For C++ app development for the N-Gage, use "Series 60 1st Edition" a.k.a. version 1.2 SDKs.

    Pick the SDK 1.2 version that supports the IDE you want to use (Visual C++, Borland or CodeWarrior).

    Besides the SDK documentation, code samples, and other docs on http://forum.nokia.com/series60, consider also buying this book: http://forum.nokia.com/main/1,6566,40_2,00.html

  3. #3
    Registered User
    Join Date
    Sep 2004
    Posts
    31
    Thanks Petrib,

    I have MS VS6 installed and have installed the S60 SDK v1.2, So Im feeling hopeful

    I have copied over 'avkonappwiz.awx' and 'avkonappwiz.hlp' to enable the s60 wizard, but whenever I try this it errors. (it gives error 0x8004a004 but I think It might be cos im using winxp, and im sure there was something written about that, it looks like it creates the project as the folders and files exist but it doesnt open it automatically)

    Following the help files to run the animation example on the emulator I have changed to the animation/gui/group file and tried to run the command 'bldmake bldfiles' to which I get the error, Perl is not recognised as a program etc etc.. Do I need to install this too?

    Im still stumped!, this seems much harder than it needs to be, am I doing something silly?

    Please help!

    Cheers
    Jamie

  4. #4
    Registered User
    Join Date
    Sep 2004
    Posts
    31
    UPDATE:

    I have now managed to do it, I did have to install PERL that sorted out that problem. There was another problem with the epoc not running due to me installing my SDK on my E: instead of C: but I found the solution for that on the forums.

    All in all its a bloody chore to get this thing up and running. Just hope its worth it!

    Thanks for your help though Petrib.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×