×

Discussion Board

Results 1 to 6 of 6
  1. #1
    Registered User
    Join Date
    Jul 2005
    Posts
    2

    Angry version conflict CLDC 1.0 / 1.1

    Hi
    Please I need immedeate help.
    I am currently making a game in NetBeans 4.1(java IDE) and using the nokia series 60 emulator.
    The app is comiled with MIDP 2.0 and CLDC 1.1 setting. The complete game has been developed but now when i test the game on aa phone, it is not running on any phone( even the ones which are MIDP 2 and CLDC 1.1 compliant ) this includes nokia 3230 ( CLDC 1.1 and MIDP 2.0 comp)

    However when I create a blank app of CLDC 1.0 and MIDP 2.0 its successfully running on
    the nokia 3230. whereas with MIDP 2.0 & CLDC 1.1 it fails to even Install. The error shown is "Invalid version".

    Please any sort of help will be greatly appeciated.

    Thanks
    Saaransh Bagga

  2. #2
    Super Contributor
    Join Date
    Mar 2003
    Location
    Finland
    Posts
    9,553
    The 3230 is a CLDC 1.0 phone, like all phones based on "Series 60 2nd Edition, Feature Pack 1" a.k.a. "Series 60 2.1). Such phones are the 3230, 6260, 6620, 6670 and 7610, at least.

    The Forum Nokia specs are wrong in this respect, if they still claim CLDC 1.1 for the 3230.

  3. #3
    Registered User
    Join Date
    Jul 2005
    Posts
    2
    just one more that i wanted to know. What sort of error do we get while installing conflicting versions of the java app that we have developed. Is it "invalid version" or "unknown file format". Or , will the application fail to install or the app fails to execute ( install successfully) if the version is conflicting.

    Thanks

  4. #4
    Registered User
    Join Date
    Jul 2005
    Posts
    1
    I've hit this issue within 1 day of purchasing a 3230 and I'm very disappointed. I purchased it specifically for J2ME development (just starting)

    The Nokia site says nothing about the CLDC spec, the forum site STILL says CLDC 1.1.

    I phoned the 75p/min expensive support line and it was inferred that Nokia does not claim responsibility for the content of Nokia Forum (despite it being copyrighted to Nokia. I am expecting a follow up.

    Anybody know here do I find the real spec. for this phone?

    Many Thanks
    Ian Hunter

  5. #5
    Registered User
    Join Date
    Aug 2008
    Location
    Bangalore
    Posts
    4

    Re: version conflict CLDC 1.0 / 1.1

    Acutally nokia 3230 is cldc 1.0.. i wrote a java 2d game in cldc 1.0 and midp 2.0.. it works fine on my 3230 phone.. but a m3g game written by me in cldc 1.1 doesn even get installed.. says invalid version..is there any way to install cldc 1.1 config package on this phone??

  6. #6
    Super Contributor
    Join Date
    Mar 2003
    Location
    Finland
    Posts
    9,553

    Re: version conflict CLDC 1.0 / 1.1

    That's what I said in 2005; 3230 is CLDC 1.0.

    There is no way for you to "upgrade" or install CLDC 1.1 support on the 3230 (or any phone that doesn't come with the support from the manufacturer).

    Your options are:
    - do not support such devices
    - rewrite your application (or modify whatever you do that only works in CLDC 1.1 to also work in CLDC 1.0)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×