×

Discussion Board

Results 1 to 7 of 7
  1. #1
    Regular Contributor
    Join Date
    Oct 2004
    Posts
    158

    Issues with 1.1.5

    Hi,

    A few things I ran into with my 6600:

    1. Accessing the camera does not work with the 'fast' version of the Python runtime. Details fail me because I deinstalled the fast version and didn't write down the error. I remember it was in camera.py line 11 where it tries to import something like _camera.pyd (which doesn't exist).
    2. The default (and only) camera exposure mode in the normal Python runtime still is 'night'.
    3. selection_lists do not cover the complete screen. This is notable when running the application in 'large' or 'full' mode.

    More later.

    I would encourage you to keep developing the 'fast' version because the speed increase is incredible! Keep up the good work.

    Cheers,
    Berco

  2. #2
    Regular Contributor
    Join Date
    Aug 2004
    Posts
    66
    When we can test new version 1.1.6 ?
    And when we can create commercial application with the final 1.2.0 ?

  3. #3
    Regular Contributor
    Join Date
    Oct 2004
    Posts
    158
    3. is still not solved in 1.1.6

  4. #4
    Regular Contributor
    Join Date
    Sep 2003
    Location
    Finland
    Posts
    209

    Re: Issues with 1.1.5

    Originally posted by bercobeute

    2. The default (and only) camera exposure mode in the normal Python runtime still is 'night'.
    3. selection_lists do not cover the complete screen. This is notable when running the application in 'large' or 'full' mode.
    2. Could you clarify this?

    3. This is a defect, reported as #0225. Notice that this defect also shows with "multi_selection_list". Thanks for reporting this one!

  5. #5
    Regular Contributor
    Join Date
    Oct 2004
    Posts
    158
    2. On a 6600 with 1.1.5, 1.1.6 and 1.1.6_fast this:

    Code:
    exposures = camera.exposure_modes()
    only returns the exposure mode 'night'. Daylight pictures are way to bright.

  6. #6
    Regular Contributor
    Join Date
    Sep 2003
    Location
    Finland
    Posts
    209
    Originally posted by bercobeute
    2. On a 6600 with 1.1.5, 1.1.6 and 1.1.6_fast this:

    Code:
    exposures = camera.exposure_modes()
    only returns the exposure mode 'night'. Daylight pictures are way to bright.
    The automatically supported mode 'auto' is not included in the returned list. The default parameters for "take_photo" nevertheless include the 'auto' parameter for exposure which you can also use in your code despite the fact that the accessor does not return it.

    The list should (probably) return also 'auto', this concerns also other accessors in "camera". Filed as #0226, we need to think about whether the 'auto' should be included in the list or should it be e.g. a module level constant. Thanks for noticing also this one!

  7. #7
    Regular Contributor
    Join Date
    Oct 2004
    Posts
    158

    Re: Issues with 1.1.5

    ...but on the 6600 even explicitely using the 'auto' exposure mode gives way to bright images, making it impossible to take outdoor pictures with the 6600.

    Code:
    camera.take_photo(exposure=self.exposure)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×