×

Discussion Board

Results 1 to 8 of 8
  1. #1
    Regular Contributor
    Join Date
    Mar 2003
    Location
    Finland
    Posts
    224

    Hello yucca, have you got that amr AudioStream example working?

    Hi yucca,

    I am waiting for your response. Could you please tell me about it.

    Regards,

    shagor

  2. #2
    Nokia Developer Moderator
    Join Date
    Mar 2003
    Location
    Lempäälä/Finland
    Posts
    29,167
    it was indeed taken from a project where it was working completely fine. The buffer played was done using the same methods.

    Anyway, you might want to read topics in NewLC to gain some knowledge about AMR, so you could get it working easir.

    anyway, just remember to cut-away the 6 byte header of the file, and then use right types of AMR files in it. and it will work just fine.

    yucca

  3. #3
    Regular Contributor
    Join Date
    Mar 2003
    Location
    Finland
    Posts
    224

    Thanks a lot, yucca.

    Audio streaming is working quite nice now.
    Everything was actually fine. The problem was the 6-Bytes header. So before processing it, I cut the 6-Bytes from the header.

    Regards,
    shagor

  4. #4
    Registered User
    Join Date
    May 2003
    Posts
    187

    Re: Hello yucca, have you got that amr AudioStream example working?

    Hi ,

    If I want to play AMR from a Descriptor , should I remove the 6 byte as well?

  5. #5
    Registered User
    Join Date
    May 2003
    Posts
    187

    Re: Hello yucca, have you got that amr AudioStream example working?

    Hi ,

    If I want to play AMR from a Descriptor , should I remove the 6-8 bytes as well?

  6. #6
    Nokia Developer Moderator
    Join Date
    Mar 2003
    Location
    Lempäälä/Finland
    Posts
    29,167

    Re: Hello yucca, have you got that amr AudioStream example working?

    it depends if the descriptor has the header in it. The example code was used in a project where I was recording the AMR buffer by myself, so was not needing that header there and thus the cutting of the header was commented out from that code.

    yucca

  7. #7
    Registered User
    Join Date
    May 2003
    Posts
    187

    Re: Hello yucca, have you got that amr AudioStream example working?

    Hi yucca,

    Do you know if I can get the audio streaming working on the emulator?
    If yes what's the configuration I need to do ?

    Regards,
    Rami
    Last edited by rami75lu; 2005-09-01 at 13:40.

  8. #8
    Nokia Developer Moderator
    Join Date
    Mar 2003
    Location
    Lempäälä/Finland
    Posts
    29,167

    Re: Hello yucca, have you got that amr AudioStream example working?

    hmmm, I've been running that code in 1.2 as well as in 2.1 SDK, and it has been awhile since I installed any of them. Anyway, if I remember right, 2.1 didn't need any extra stuff to be installed, but with 1.2, there was some extra packet that needed to be installed to get the streaming working. Anyway, I could also remember this wrong, or they could have added the stuff in latest SDk's, anyway, if it is not working, search the downloads section for anything that might be usefull.

    yucca

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×