×

Discussion Board

Results 1 to 4 of 4
  1. #1
    Registered User
    Join Date
    Jul 2005
    Posts
    10

    Application doesn't work when installed in MMC

    Hi,
    In my application I use some bitmaps. When I install the SIS in phone memory, the image loads. But if I install it in MMC it doesn't work. In the .pkg file I use the target "\system\apps\ " Where do I store application specific image(not MBM) so that it should work both in phone memory and MMC . please help

    thanks
    Sreejesh

  2. #2
    Regular Contributor
    Join Date
    Mar 2003
    Location
    UK
    Posts
    159
    Try using a target of "!\system\apps\", that "!" tells the install system to install to the drive the user selected.

    Also check your app is nor hard coding where to read from, if you're always trying to read from "c:\" then of course you're not going to find anything on the memory card.

  3. #3
    Registered User
    Join Date
    Jul 2005
    Posts
    10
    Hi,
    Thanks, I used the target as "!\system\apps\", but in code I used
    C:\\system\\apps\\ Can I use same ! in the code also? or any other way..

  4. #4
    Registered User
    Join Date
    Aug 2003
    Location
    Oulu, Finland
    Posts
    1,122
    You can get your installation path from Application()->AppFullName(). The first character there is the drive letter your application is installed on. Or you can use TParse to parse the application path to other meaningful parts.

    Lauri

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×