×

Discussion Board

Results 1 to 3 of 3
  1. #1
    Registered User
    Join Date
    Dec 2004
    Posts
    23

    Question Installed MIDlet is disabled on 6230i, but enabled on 6230

    Hi,

    I have a MIDlet (CLDC 1.1 and MIDP 2.0) that I installed using PC Suite 6.6 on my Nokia 6230 and it runs fine, as expected because it runs fine in the emulator. The MIDlet uses Bluetooth to communicate with another device.
    The same MIDlet runs fine in the 6230i emulator, but when installed on a friend's 6230i, again using PC Suite 6.6 the MIDlet is installed, but is disabled and the only thing I can do is delete it from the phone.

    I developed the MIDlet using NetBeans 4.1 with the Mobility Pack, and used the Series 40 SDK 2.0 and the Series 40 SDK 2.0 for 6230i from Nokia which I installed as a platform in NetBeans.

    On both emulators the game runs fine, but only on the real 6230.

    Installation on the 6230i is done using Bluetooth as well as USB-cable.

    Can anybody explain to me what's going on, and more importantly maybe, what to do to fix it?

    Thanks in advance,
    Iwan

  2. #2
    Super Contributor
    Join Date
    Nov 2003
    Location
    Bangalore , India
    Posts
    4,430

    Re: Installed MIDlet is disabled on 6230i, but enabled on 6230

    Hi,

    Could you make sure that the JAD/MF entries are matching each other and are correct?

    regards
    Gopal

  3. #3
    Registered User
    Join Date
    Dec 2004
    Posts
    23

    Re: Installed MIDlet is disabled on 6230i, but enabled on 6230

    Hi apart from the order of the declarations, the following lines are missing from the MF:

    MIDlet-Jar-Size: 75116
    MIDlet-Jar-URL: Mong.jar

    Should I put those in?

    Iwan

Similar Threads

  1. Every time when Midlet launches on 6230 I need to confirm manually..
    By dusanbaranec in forum Mobile Java General
    Replies: 3
    Last Post: 2005-04-13, 09:33
  2. 6230: OTA Logos with newer Vodafone SIM-Cars disabled?!
    By kesslerdesign in forum Smart Messaging
    Replies: 4
    Last Post: 2005-04-06, 21:01
  3. Checking if a MIDlet is installed with WAP
    By shmoove in forum Mobile Web Site Development
    Replies: 1
    Last Post: 2005-03-31, 07:21
  4. Extreme Problems accessing the Camera by an Midlet on the NOKIA 6230
    By n3po in forum Mobile Java Media (Graphics & Sounds)
    Replies: 1
    Last Post: 2005-01-24, 09:36
  5. Replies: 1
    Last Post: 2005-01-13, 21:01

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •