×

Discussion Board

Results 1 to 7 of 7
  1. #1
    Registered User
    Join Date
    Aug 2005
    Posts
    35

    error while building a sample application for series 60 sdk 2.1 for symbian OS

    Hi all..

    i am interested in building an application for series 60 sdk 2.1 for symbian OS supporting Microsoft Visual c++ .NET i have downloaded the required software but i have a problem running a sample application ( "Helloworldbasic" application). there was an error with 'build solution' which states:

    error: a tool returned an error code from "Building resources from Helloworldbasic.rss"
    'nmake' is not recognized as an internal or external command, operable program or batch file.

    can anyone help me out from overcoming this error.

    Thanks in advance
    Deepthi.

  2. #2
    Nokia Developer Moderator
    Join Date
    Mar 2003
    Location
    Lempäälä/Finland
    Posts
    29,168

    Re: error while building a sample application for series 60 sdk 2.1 for symbian OS

    you should check that your environment variables are set correctly. With VC6 at least they were set automatically during installation, if you just remembered to tick the box for it.

    yucca

  3. #3
    Super Contributor
    Join Date
    Sep 2004
    Posts
    1,048

    Re: error while building a sample application for series 60 sdk 2.1 for symbian OS

    Hello,

    From your post it is not clear that you would be using NDS, but from the error that seems to be the case.

    Assuming that you are using NDS, then NDS only supports full Visual Studio, not Visual C++ .NET so there is no guarantee that this can be made to work.

    However from the error it seems that the concrete problem is that there is no valid path to NMAKE. In Visual Studio, NMAKE can be found in
    C:\Program Files\Microsoft Visual Studio .NET 2003\Vc7\bin

    and there should be a path variable set if Tools -> Options -> Project -> VC++ directories that point to that directory. If you can find the same information for VC++, then you can always give it a try.

  4. #4
    Registered User
    Join Date
    Aug 2005
    Posts
    35

    Re: error while building a sample application for series 60 sdk 2.1 for symbian OS

    Hi mitts n symbianyucca,

    Thanku for your response. let me tell the softwares i downloaded:
    java - j2re1.4.2_09
    activeperl - 5.8.7
    SDK - 2.1 (series 60)
    NDS - v1.1
    in the same order

    As mitts suggested me to check the 'nmake' path variable set in Tools->options->project->vc++ directories, i found that the path was not included in the executable directories. so i included the path myself n ran the application but the build was unsuccessful, there was an error message window stating:

    cl.exe - unable to locate component
    This application has failed to start because mspdb71.dll was not found.Reinstalling the application may fix this problem.
    OK

    i pressed OK and noticed an error in the output window which says: " error result returned from 'cl.exe'." cl.exe is also present in the bin folder as 'nmake'.
    what might be the error and is there a means to overcome it.

    Symbianyucca, u asked me to check the environment settings.. can u be more clear about what all should be checked..

    Thanku
    Deepthi.

  5. #5
    Registered User
    Join Date
    Aug 2005
    Posts
    35

    Re: error while building a sample application for series 60 sdk 2.1 for symbian OS

    Hi

    i tried adding 'mspdb71.dll' to the vc++ directories present in Tools->options->project and got the buils solution done successfully and started debugging by debug->start. the emulator didnot display anything. in the output window it gives ' no symbols loaded' from epoc.exe repeatedly..
    i dont know whether this might be the problem or someother thing. if it is..
    how can i load symbols so that my application can be viewed on the emulator?

    Thanku
    Deepthi.

  6. #6
    Registered User
    Join Date
    Jul 2004
    Posts
    25

    Re: error while building a sample application for series 60 sdk 2.1 for symbian OS

    Can you build the example using dos and tools like bldmake and abld. Then see whether your application is visible in emulator.
    Thanks,

  7. #7
    Super Contributor
    Join Date
    Sep 2004
    Posts
    1,048

    Re: error while building a sample application for series 60 sdk 2.1 for symbian OS

    Deepthis,

    The message about missing symbols is OK. When the emulator starts up the initial emulator application does not provide debug info (you cannot debug the emulator itself). Just continue and you should be able to get access to the code once you start up the application from the emulator user interface.

Similar Threads

  1. fail to run the midlet application in series 60 midp sdk 2.1 beta
    By chailee in forum Mobile Java Tools & SDKs
    Replies: 1
    Last Post: 2004-11-17, 11:11
  2. Some exceptions in RemoteCam sample application.
    By susanto_waluyo in forum Symbian
    Replies: 5
    Last Post: 2003-11-03, 06:38
  3. Does PC Connectivity SDK 2.1 support 3310?
    By carebear123 in forum PC Suite API and PC Connectivity SDK
    Replies: 1
    Last Post: 2002-10-25, 19:30
  4. Some exceptions in RemoteCam sample application.
    By susanto_waluyo in forum Smart Messaging
    Replies: 0
    Last Post: 2002-07-31, 05:58
  5. ReDistribution of Application created with SDK 2.1
    By darrenthompson in forum PC Suite API and PC Connectivity SDK
    Replies: 1
    Last Post: 2002-07-10, 06:08

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×