×

Discussion Board

Results 1 to 2 of 2
  1. #1
    Regular Contributor
    Join Date
    Mar 2003
    Posts
    124

    I'm doing a wap project on a Nokia 7110 mobile phone. I had a deck which co

    I'm doing a wap project on a Nokia 7110 mobile phone. I had a deck which consists of 15 cards using "ontimer" to swap the cards. When implemented on the mobile phone. It flash the first card, connect to service, flash the second card, connect to service again, flash the third card and connect to service again, so on and so for. This there any solutions beside owning a GPRS phone that I can download the deck of cards without "connecting to service".

  2. #2
    Regular Contributor
    Join Date
    Mar 2003
    Posts
    194

    RE: I'm doing a wap project on a Nokia 7110 mobile phone. I had a deck which co

    The whole WML deck is downloaded at once with all the cards included. However, images are downloaded separately once the card is referenced and the card is rendered. One possible workaround for the given problem is to download all the pictures into the cache of the WAP browser in advance. One way to do this is to first visit a card where all the pictures are referenced and immediately move to next card either with ontimer or onenterforward before the pictures are actually rendered into the screen. The pictures should now have been downloaded into the cache. The problem is actually only valid for older 7110 sw versions. The newer 7110 sw versions and all the newer Nokia WAP capable phones do not show "connecting to service" when downloading a picture. Neither is the problem in any way related to the lack of GPRS.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×