×

Discussion Board

Results 1 to 3 of 3
  1. #1
    Registered User
    Join Date
    May 2005
    Posts
    19

    N70 secure socket problem

    I got the problem when using secure socket on N70 device. But mine is the J2me application.

    When i open the secure socket using port 995 to one mail server, N70 does not popup one window to notice me that it is a untrusted certificate, but 6680, 6630 does that. Then the application failed to get the secure socket.

    Any one knows how to make setting to let the device to notice me that it is a untrusted certificate, and i can confirm to pass it!

    Or any solutions for the N70.

    Thank you!

  2. #2
    Regular Contributor
    Join Date
    Dec 2003
    Location
    Germany / Cologne
    Posts
    89

    Re: N70 secure socket problem

    I guess that/your behaviour is the correct and specified behaviour. The 6680, 6630 dont't work as specified in MIDP2.0.
    The series 40 has the same behaviour and there's no way to bypass it - at least I didn't find one.
    Oliver

  3. #3
    Registered User
    Join Date
    May 2005
    Posts
    19

    Re: N70 secure socket problem

    Thank you, Olive!

    Do you have any solution for this specified feature?

    How can my midlet pass the secure socket check if there is not
    prompt for the untrusted certificate ?

    Temporarily I import the untrusted certificate into the mobile phone
    to solve this problem.
    But I need general solution.

    Could you give me some advices?

    Thank you!

Similar Threads

  1. Secure Socket read gets stuck in a loop on N70 device
    By jestyjames in forum Symbian Networking & Messaging (Closed)
    Replies: 5
    Last Post: 2007-01-08, 10:02
  2. N70 'contacts' bug problem
    By benbytes in forum General Development Questions
    Replies: 4
    Last Post: 2005-11-09, 20:41
  3. Socket connection problem with 6630
    By chandrasarav in forum Mobile Java General
    Replies: 4
    Last Post: 2005-08-24, 07:50
  4. Secure SMS Problem
    By aemrearpaci in forum General Messaging
    Replies: 4
    Last Post: 2004-11-29, 09:24
  5. TCP/IP socket connection problem
    By ArunP in forum Symbian Networking & Messaging (Closed)
    Replies: 1
    Last Post: 2002-09-19, 10:09

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×