×

Discussion Board

Results 1 to 12 of 12
  1. #1
    Registered User
    Join Date
    Jul 2004
    Posts
    3

    Carbide installation problem

    Hi all

    Im trying to install Carbide (carbide_vs_20.exe) but installation fails.

    I've VS.NET 2003 (English) with J#

    I installed the JRE, Active Perl, SDK, following the indications on this forum.

    When i start to install carbide, installAnywhere show the progress bar and when it gets to 99% it shows a message like this

    "Choose another location to extract the installer" this is not the real message i translated it because is in spanish.


    The message window has two buttons Cancel and another to choose a directory, but whatever directory i choose the installer fails. No log file is created.



    My java version is:

    java version "1.5.0_05"
    Java(TM) 2 Runtime Environment, Standard Edition (build 1.5.0_05-b05)
    Java HotSpot(TM) Client VM (build 1.5.0_05-b05, mixed mode, sharing)

    ActiveState Perl
    v5.8.7 built for MSWin32-x86-multi-thread
    Binary build 815 [211909]

    SDK series 60 2nd FP2
    s60_2nd_fp2_sdk_msb.zip

    All the software is installed in the default directory.

    C:\Perl
    C:\Symbian
    C:\Archivos de programa\Microsoft Visual Studio .NET 2003
    C:\Archivos de programa\Java

    My windows version is spanish

    Thanks in advance and sorry my poor english.
    Last edited by janek_lopez; 2005-11-19 at 13:01.

  2. #2
    Super Contributor
    Join Date
    Sep 2004
    Posts
    1,048

    Re: Carbide installation problem

    Hello,

    From your description I actually suspect that the product itself might have been succesfully installed. The last step of the installation is to launch a second installer that installs the online help. I suspect that it is this step that for some reason fails. In this case the product itself is actually OK, but will not provide online help. You can test for this by starting Visual Studio and checking the steps from the the Installation guide to verify the installation.

    As for why the second installer fails your error description unfortunately did not provide enough information.

  3. #3
    Super Contributor
    Join Date
    Mar 2003
    Location
    Finland
    Posts
    9,569

    Re: Carbide installation problem

    I don't know if it is the case with Carbide.vs at all, but very often Windows developers do not take into account that the special/system folder names are localized, too, for different localized versions of Windows.

    In other words, "C:\Program Files" seems to be "C:\Archivos de programa" in Spanish. Same with some other folders; they're translated, too.

    It could be that the installer stumbles on this, somehow (many developers do not test the installation of their apps on different language versions of Windows, but perhaps just one).

  4. #4
    Registered User
    Join Date
    Jul 2004
    Posts
    3

    Re: Carbide installation problem

    Carbide doesn't get installed.


    It only shows a first screen with a progress bar and the shows the warning messages.

    I noticed, carbide also create a directory in

    C:\Documents and Settings\myuser\Configuración local\Temp\I1132437018

    see the following snapshots

    http://server5.theimagehosting.com/i...irstscreen.JPG

    http://server5.theimagehosting.com/i...condscreen.JPG

    http://server5.theimagehosting.com/i...hirdscreen.JPG

    Any ideas?

  5. #5
    Super Contributor
    Join Date
    Sep 2004
    Posts
    1,048

    Re: Carbide installation problem

    OK, thanks for the additional information, I misunderstood your first message. I checked the support provided by the company making the installer and this seems to be a known issue with the installer for which they (the installer company) do not have a diagnosis nor workaround. Apparently it is happening mainy on Windows 2000SP4. Some users reported that a reboot fixed the issue, while others that it did not. The extractor apparently is native code so changing the Java version will not have an effect.

    Seeing that even the installer vendor cannot provide more info on this, I'm afraid there is little to be done, sorry.

  6. #6
    Registered User
    Join Date
    Jul 2004
    Posts
    3

    Re: Carbide installation problem

    I have windows xp sp2. I've rebooted many times. But no way. You mean that users with this problem could not program in c for nokias?????


    Thanks

  7. #7
    Super Contributor
    Join Date
    Sep 2004
    Posts
    1,048

    Re: Carbide installation problem

    Hi,

    Most reports on the issue indicate that the problem is very rare and random and does not seem to be connected to language versions as it is reported also for English versions of Windows. So if you have an other PC available that you can use, that might solve your problem.

    Not being able to install Carbide.vs does not prevent you from developing C+ for Nokia phones. If you are an advanced developer, the preferred tool in any case is the CodeWarrior development environment, you can pick it up from http://www.forum.nokia.com/main/0,6566,034-721,00.html.

    You can also use the S60 FP2 SDK and the included .NET support to develop in VS using just the SDK.

    Sorry for the inconvenience.

  8. #8
    Registered User
    Join Date
    May 2004
    Posts
    11

    Re: Carbide installation problem

    Hi,

    I suggest not to use the 5.8 version of Perl.
    Deinstall it and install a 5.6 version.

    I hope this helps.

  9. #9
    Registered User
    Join Date
    Feb 2006
    Posts
    1

    Re: Carbide installation problem

    Hi,
    I have the same problem.
    I am trying to install Carbide.j, but the installer stuck after the install stage.
    there was no progress bar.
    I am using WindowsXP SP2.

  10. #10
    Registered User
    Join Date
    Sep 2005
    Posts
    1

    Re: Carbide installation problem

    Carbide c++ Express, does't recognize S60 SDk Symbian\8.0a\S60_2nd_FP2...

  11. #11
    Super Contributor
    Join Date
    Sep 2004
    Posts
    1,048

    Re: Carbide installation problem

    Quote Originally Posted by chaitrax
    Carbide c++ Express, does't recognize S60 SDk Symbian\8.0a\S60_2nd_FP2...
    You most likely have the WINS version of the SDK installed. If this is the case download and install the WINSCW version. Carbide.c++ Express support is mainly provided in an other discussion group, go to http://discussion.forum.nokia.com/fo...ad.php?t=74925 .

  12. #12
    Registered User
    Join Date
    May 2005
    Posts
    1

    Re: Carbide installation problem

    Quote Originally Posted by ShaharL
    Hi,
    I have the same problem.
    I am trying to install Carbide.j, but the installer stuck after the install stage.
    there was no progress bar.
    I am using WindowsXP SP2.
    Hi,
    I have exactly the same problem with installing Carbide.j. When I start the installer the window objects (scroll bars, option buttons, etc.) are not painted corret.
    And when I com to the "Install" Stage, the installer is doing nothing. No prograss bar is visible - nothing happens.

    What to do? Who can help?
    ShaharL, did you find a workaround?

    Thanks
    Christopher

Similar Threads

  1. Installation problem
    By xavieral in forum Symbian
    Replies: 3
    Last Post: 2005-03-14, 21:07
  2. *.gdr installation problem in emulator
    By teddy_kim2003 in forum Symbian
    Replies: 0
    Last Post: 2004-09-28, 10:12
  3. NDS 2.0 Installation Problem
    By morozov in forum Mobile Java Tools & SDKs
    Replies: 2
    Last Post: 2003-11-12, 22:51
  4. NDS 2.0 installation problem
    By ary14 in forum Mobile Java Tools & SDKs
    Replies: 5
    Last Post: 2003-10-17, 21:22
  5. please answer my installation problem
    By kmaddocks in forum Mobile Java General
    Replies: 0
    Last Post: 2003-03-26, 11:20

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×