×

Discussion Board

Results 1 to 3 of 3
  1. #1
    Registered User
    Join Date
    Nov 2005
    Posts
    10

    Nokia S60 SDK and Carbide in VS.NET 7.1

    Hi to all,

    Firstly I want to say sorry if this subject is already discussed somewhere deep in the forum. Unfortunately, I was unable to find it.

    I've installed ActivePerl, Nokia S60 SDK and Carbide. But when I try to build the Hello World carbide template, it fails with a Pre-Build tool error. As I checked the output I noticed that the epocroot variable is incorrect. It's pointing to an inproper location of the SDK(actually it's the previous location of the SDK, but I've reinstalled both the SDK and Carbide with no success), so I get a 'No such file or directory' error. If I check the Project\SDK Configuration Manager\Enable-Disable SDK's tab, the value in the SDK Root column by the S60 3.0 Beta is incorrect too.

    So basically my question is, How can I manually change the path to the SDK root?


    Thanks in advance
    Last edited by MePHyst0; 2005-11-27 at 11:38.

  2. #2
    Super Contributor
    Join Date
    Sep 2004
    Posts
    1,048

    Re: Nokia S60 SDK and Carbide in VS.NET 6.0

    Hi,

    Your questions does not provide all the info to make a full analysis, but here is a proposal:

    For the EPOCROOT, if you mean that the EPOCROOT in the Visual Studio Output window during building is incorrect, then this is due to you having Enabled the corresponding SDK and then later moved te SDK without re-enabling the SDK. The SDK root is "fixed" wen it is enabled.

    To fix this, go into the SDK Configuration Manager, then select Enable/Disable SDKs at the bottom. Unselect the offending SDK and then close the wizard. Reopen the wizard, again go to Enable/Disable SDKs and select the SDK. It should now be set up with the correct EPOCROOT. This step only needs to be done once.

    If you also created projects while you had the SDK in the initial location, the project build configurations will also be set up to point to the old SDK location and will not work. To fix this, you could simply go into the main portion of the SDK Configuration Manager (this step must be done for each project) and first disable the offending SDK, then close, then open the SDK Config manager and then re-enable the desired SDK.

    Only if this was the S60 3.0, there is a catch as you cannot disable just a single configuration (the tool does not allow you to remove all). In this case what you need to do is to use the Visual Studio's own config manager to remove the incorrect configuration. Do like this: In the build configuration menu at the top of the window, select the last item "Configuration manager...". In the window that now appears, in the topmost drop-down menu, select again the last option "<Edit...>". In the window that you now get, select the S60 3.0 configration(s) for WINSCW and GCCE and Remove them. Close all windows. Go into the Carbide "SDK Configuration Manager" and select the S60 3.0 SDK, this will recreate the build configurations with the desired content.

    Once you have done this, let's see if we can address your initial problem.

  3. #3
    Registered User
    Join Date
    Nov 2005
    Posts
    10

    Re: Nokia S60 SDK and Carbide in VS.NET 6.0

    Thanks a lot for your extensive help. I tryed the last option you've mentioned, adjusting the path in VS configuration manager, and it didn't help. Currently I'm downloading a new SDK, I'll have 2 SDK's, so I can disable the S60 SDK, then enable it again, and wait what will happen :) I'll report..

Similar Threads

  1. Carbide or NDS 1.1 with S60 2nd Ed FP1 SDK?
    By dsreich in forum Symbian Tools & SDKs
    Replies: 1
    Last Post: 2005-11-08, 07:40

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×