×

Discussion Board

Results 1 to 8 of 8
  1. #1
    Regular Contributor
    Join Date
    Nov 2005
    Location
    Amman/Jordan
    Posts
    322

    a problem with s60 3rd editionsdk for symbian os?

    hi there ...

    after downloading the s60 3rd edition sdk for symbian os, for c++ .. when i verify command tool line ... in order to make sure that the sdk is functioning correctly ................whne i do the <bldmake bldfiles> command
    this warning applears ( can not determinether version of the RVCT compiler ...)
    after that if i perform the <abld build> command and then the <epoc> the emulater do nothing.....
    whats wrong than ..?

  2. #2
    Super Contributor
    Join Date
    Mar 2003
    Location
    Finland
    Posts
    9,563

    Re: a problem with s60 3rd editionsdk for symbian os?

    You need to install the GCCE compiler as a separate step and use it as the target (unless you have purchased RVCT from ARM Ltd, in which case you need to install it).

  3. #3
    Regular Contributor
    Join Date
    Nov 2005
    Location
    Amman/Jordan
    Posts
    322

    Re: a problem with s60 3rd editionsdk for symbian os?

    Quote Originally Posted by petrib
    You need to install the GCCE compiler as a separate step and use it as the target (unless you have purchased RVCT from ARM Ltd, in which case you need to install it).
    hmm from where shall i download it ...???
    and by the way i discovered that the windows is xp proffisional not sp1 ... this may be the problem right ..?

  4. #4
    Super Contributor
    Join Date
    Mar 2003
    Location
    Finland
    Posts
    9,563

    Re: a problem with s60 3rd editionsdk for symbian os?

    The GCCE is part of the SDK and you already have it, if you have the S60 3.0 beta SDK. Read the release notes and the installation guide documents.

    The RVCT compiler costs a (relatively big) bundle and is sold by ARM Ltd., or resellers.

  5. #5
    Super Contributor
    Join Date
    Mar 2003
    Location
    Finland
    Posts
    9,563

    Re: a problem with s60 3rd editionsdk for symbian os?

    You might also want to read this Symbian FAQ (Frequently Asked Question).

  6. #6
    Registered User
    Join Date
    Mar 2003
    Posts
    1

    Re: a problem with s60 3rd editionsdk for symbian os?

    Quote Originally Posted by dakoz
    whne i do the <bldmake bldfiles> command
    this warning applears ( can not determinether version of the RVCT compiler ...)
    This warning is safe to ignore.

    Quote Originally Posted by dakoz
    after that if i perform the <abld build> command and then the <epoc> the emulater do nothing.....
    whats wrong than ..?
    What are you building? Do you get any output during 'abld build' and which target platforms are specified in the .mmp file? WINSCW?

    Also, when you start the emulator, it does take a while for it to start and it doesn't automatically start your application. You need to navigate to it and start it.

    /Cruizer.

  7. #7
    Registered User
    Join Date
    Nov 2004
    Posts
    11

    Re: a problem with s60 3rd editionsdk for symbian os?

    Hopefully there is a final SDK for 3rd edition. With the beta edition, I hear lots of bug/errors still around. Combine with Symbian signed cost, buggy SDK, the device short life time (before we publish our software, new phone models will come with slightly modification that request rework of our softwares, remember Nokia 6600, 7610, 6680 and even N70. There are no guarantees that the softwares you make for one model will work smoothly for other model).
    I wish that Nokia/Symbian will do something before lots developers will abandoned this platform. However, the market will sort out quickly who will become the predominant platfom for mobile apps development.
    Last edited by symbianx; 2005-11-30 at 07:35.

  8. #8
    Registered User
    Join Date
    May 2004
    Posts
    11

    Re: a problem with s60 3rd editionsdk for symbian os?

    Actually, I think the App does start automatically on the
    3rd edition Emulator as soon as the Emu has booted up
    correctly ...

    You can switch to the App via the task list (press the left mouse
    button over the Emu's menu button for a few seconds)

    c.

Similar Threads

  1. Carbide.vs & S60 3rd edition Beta problem
    By alias133 in forum Mobile Java Tools & SDKs
    Replies: 2
    Last Post: 2005-11-14, 04:59
  2. Connection problem between s40 and s60
    By skevelim in forum Mobile Java Networking & Messaging & Security
    Replies: 3
    Last Post: 2005-07-04, 10:57
  3. problem with "sendas" example in s60 SDK
    By deepakrvce in forum Symbian Tools & SDKs
    Replies: 0
    Last Post: 2005-03-02, 06:24
  4. S60 emulator problem
    By petokala in forum Bluetooth Technology
    Replies: 5
    Last Post: 2002-12-20, 13:21
  5. solution: S60 application icon problem
    By Nokia_Archive in forum Symbian Tools & SDKs
    Replies: 0
    Last Post: 2002-06-03, 02:43

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×