×

Discussion Board

Results 1 to 4 of 4
  1. #1
    Registered User
    Join Date
    Nov 2005
    Posts
    3

    web-server on symbian-phone

    Dear Symbian-friends,

    I've got the following problem: I've written a web-server for a Symbian Series 60 Smartphone (runs on 127.0.0.1:80 on my phone) - when I want to access a page from the standard-browser, I get the error message "No connection...". I've set the settings in my browser: Local IP-address = 127.0.0.1....

    It would be great if anyone could help me,
    thanks a lot in advance.

    Ronald

  2. #2
    Regular Contributor
    Join Date
    Mar 2003
    Posts
    67

    Re: web-server on symbian-phone

    I did the same thing and it worked. (N6600 FW 4.09.1)

    I found out that the device's default browser always want's to make an internet connection via the default APN but that is no problem.

    The only problem would be if you have a proxy server configured for your default APN. If you don't have a proxy configured it should work.

    Regards
    Björn

  3. #3
    Registered User
    Join Date
    Nov 2005
    Posts
    3

    Re: web-server on symbian-phone

    Well, as I found out (http://www3.symbian.com/faq.nsf/0/2E...?OpenDocument), you have to select an IAP (and connect to it, even if you don't need to...) - so, I created my own Acces-Point in the standard-browser, but this doesn't work ("no packets - check your connection...") - but using the same (own) IAP with the Opera-Browser works... The problem is, that I have to use the standard browser :-)
    Do you always have to select the IAP when connecting to your server? I don't really know if you can create your own IAP with a program, and start the browser with those settings then...

    Ronald

  4. #4
    Registered User
    Join Date
    Dec 2005
    Posts
    1

    Re: web-server on symbian-phone

    Hi everybody,
    I'm trying to develop a http server in j2me. It runs on 127.0.0.1:80 and works fine in the simulator. But when I tried it in the phone (a nokia 6600) I had the same problem with the default browser (it always tries to make an internet connection). So, I've tried with the opera browser using a IAP of my own as you did, but it didn't work. I've also tried the VS Httpd (a symbian native simple http server) running on 127.0.0.1:80 and it didn't work too.

    How should I configure my own IAP to make the opera browser connect to the local server?

    Thanks.

Similar Threads

  1. Uploading File From Series-60 Phone To Web Server Thru C++ Application?
    By periakaruppan in forum Symbian User Interface
    Replies: 0
    Last Post: 2005-06-02, 11:05
  2. Uploading File From Series-60 Phone To Web Server Thru C++ Application?
    By periakaruppan in forum Symbian Tools & SDKs
    Replies: 0
    Last Post: 2005-06-02, 11:04
  3. Global Symbian Development Opportunities *High Importance*
    By sara.lindsay in forum Symbian C++
    Replies: 2
    Last Post: 2004-05-08, 09:09
  4. Symbian app needs to communicate with java web server
    By creaner in forum General Development Questions
    Replies: 0
    Last Post: 2003-11-18, 18:15
  5. mms content retrival from web server
    By zhujw in forum General Messaging
    Replies: 1
    Last Post: 2003-03-17, 21:11

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •