×

Discussion Board

Results 1 to 3 of 3
  1. #1
    Registered User
    Join Date
    Dec 2005
    Posts
    17

    6600 HTTP problem

    hi i have written a midlet that reads some values from an internet site and shows it in the mobile phone. it works fine in j2me emulators,Nokia 6230,Nokia 3230 but when i try to run it in S60 Emulator Device or deploy it in Nokia 6600, it asks for permission to connect to internet and when u say yes, it just turns to white and nothing happens.

    the error is here

    Code:
    java.io.IOException: -5120
     - com.symbian.midp.io.protocol.http.HttpConnectionNative.throwIOException(), bci=5
     - com.symbian.midp.io.protocol.http.HttpConnectionNative.waitForTransaction(), bci=33
     - com.symbian.midp.io.protocol.http.HttpConnectionNative.sendRequest(), bci=309
     - com.symbian.midp.io.protocol.http.HttpConnectionNative.ensureResponse(), bci=37
     - com.symbian.midp.io.protocol.http.HttpConnectionNative.openDataInputStream(), bci=29
     - com.symbian.midp.io.protocol.http.HttpConnectionNative.openInputStream(), bci=1
     - Http.getViaHttpConnection(), bci=22
     - Veri.start(), bci=26
     - BorsaMain.startApp(), bci=4
     - javax.microedition.midlet.MIDletInvoker.invokeStartApp(), bci=1
     - com.symbian.midp.runtime.MIDletScheduler.startMIDlet(), bci=26
     - com.symbian.midp.runtime.MIDletScheduler.run(), bci=14
    plz help!
    Last edited by scriptr; 2005-12-01 at 15:23.

  2. #2
    Registered User
    Join Date
    Dec 2005
    Posts
    17

    Re: 6600 HTTP problem


    ok i solved it just added "javax.microedition.io.Connector.http" to API Permissions and now it works.

  3. #3
    Registered User
    Join Date
    Mar 2003
    Posts
    23

    Re: 6600 HTTP problem

    Are you using HTTP GET Or HTTP POST. Also can you attach the code snippet. My MIDlets connect to HTTP in all Nokia handsets including 6600.

Similar Threads

  1. Nokia 6600 Network (Http and Socket) connections do not work!
    By jimmichr in forum Mobile Java Networking & Messaging & Security
    Replies: 11
    Last Post: 2006-07-14, 07:48
  2. Replies: 1
    Last Post: 2004-06-28, 08:48
  3. Series 40 phones HTTP POST problem
    By jessicay in forum Mobile Java Networking & Messaging & Security
    Replies: 0
    Last Post: 2004-06-23, 01:01
  4. Nokia 6600 Network (Http and Socket) connections do not work!
    By jimmichr in forum Mobile Java General
    Replies: 2
    Last Post: 2003-11-23, 20:42
  5. J2ME HTTP Post problem
    By gilfr in forum Mobile Java General
    Replies: 2
    Last Post: 2003-06-11, 08:13

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×