×

Discussion Board

Results 1 to 7 of 7
  1. #1
    Registered User
    Join Date
    Oct 2005
    Posts
    4

    KErrUnknown when responding to SIP Subscribe

    Hi,

    I am struggling trying to get the SIP Subscribe to work between two emulators. I have two emulators S60 2nd Ed FP2 and the SIP plugin v4. I am also using the Nokia Sip Server emulator.

    Both emulators register ok with the registrar. I then use one emulator to SIP SUBSCRIBE to the other. The message is received on the 2nd emulator with the IncomingRequest() is invoked.

    The problem occurs when I try to send a response using the following....

    CSIPResponseElements* resp = CSIPResponseElements::NewLC(200, _L8("OK"));
    aTransaction->SendResponseL(resp);
    CleanupStak::Pop(resp);
    delete aTransaction;

    The call to SendResponseL always fails with KErrUnknown (-19).

    Has anyone experienced this before or help me out at all? Any help will be most appreciated!

  2. #2
    Super Contributor
    Join Date
    Oct 2005
    Location
    Hyderabad,India
    Posts
    1,156

    Re: KErrUnknown when responding to SIP Subscribe

    hi,
    have you solved the problem with SUBSCRIBE.Im stuck on it and like to have some ideas on the same.It would be highly appreciable if you could send me some clues on SUBSCRIBE with some codes.
    looking forwards
    thanks and regards
    Priju

  3. #3
    Registered User
    Join Date
    Oct 2005
    Posts
    4

    Re: KErrUnknown when responding to SIP Subscribe

    Hi Priju,

    Sorry, I never managed to solve this problem myself.

    I have not really had a chance to get this this to work. Not sure whats going wrong as KErrUnknown is not a helpful code!

    I was running the 2 emulators and the Nokia Sip Server all on a single PC and one thing I wanted to try was separate all these onto separate machines. Are you running these all on one machine too? If you do get it to work, please let me know.

    Many Thanks

    Omer

  4. #4
    Super Contributor
    Join Date
    Oct 2005
    Location
    Hyderabad,India
    Posts
    1,156

    Re: KErrUnknown when responding to SIP Subscribe

    hi Omer,
    thanks for the prompt reply!
    could you please send me some sample codes or something so that i can work on that! i tried with some codes.But it doesnt work out! It breaks when the CSIPSubscribeDialogAssoc class object is been created.I really wonder Y!
    Are you running these all on one machine too?
    No,im trying it on different machines with the emulator running in one of the machines!
    hope you can throw some lime light in it!
    looking forward,
    Regards
    Priju

  5. #5
    Regular Contributor
    Join Date
    Aug 2005
    Posts
    66

    Arrow Re: KErrUnknown when responding to SIP Subscribe

    Hi
    i am using subscribe method to know the presence status of the remote user,but i am getting -11 error when sendsubscribeL() is invoking with SIPSubscribeDialogAssoc object. so what may be wrong in my code.
    yours code is already working for Sending subscribe. if you send code snippets for that is more helpful for me.plz send to my personel ID satya3050@yahoo.com


    Thanks in advance

    Regards
    satya

  6. #6
    Super Contributor
    Join Date
    Oct 2005
    Location
    Hyderabad,India
    Posts
    1,156

    Re: KErrUnknown when responding to SIP Subscribe

    Send U!
    i like to know which is the server you are using. Does it support PRESENCE?

    Priju

  7. #7
    Registered User
    Join Date
    Mar 2003
    Posts
    30

    Red face Re: KErrUnknown when responding to SIP Subscribe

    Quote Originally Posted by Priju Jacob Paul
    Send U!
    i like to know which is the server you are using. Does it support PRESENCE?

    Priju
    Hi Priju!

    I'm facing the SUBSCRIBE problem in 2.2SDK too, and I'm a bit lost, because I couldn't find any piece of code to start from. The only thing I could find is a piece of code for 3rd ED, so I'm not sure if the problems I'm having are due to my adaptation.
    Please, Priju, would you be so kind as to share the "SUBSCRIBE" creation procedure with me? Anyway, have you solved it? Although the answer is "still not", your code will be a great help for me (as Satcha said, better than having nothing).

    By the way, under my point of view you're going to need a REAL server soon, as I think it's no possible to test presence with Nokia's emu.
    By my side, I'm working against SER Sip Server (http://www.iptel.org/ser/) which is free and it has a Presence Module. It runs under Linux.

    Cheers!
    F.Alvarez

Similar Threads

  1. JAIN SIP and Symbian C++ SIP
    By RyanSantos in forum Symbian Networking & Messaging (Closed)
    Replies: 11
    Last Post: 2008-07-25, 15:44
  2. SIP: BYE/ 481 (No Dialog Found)!!!!!!!!!!
    By Mini Pillai in forum Symbian Networking & Messaging (Closed)
    Replies: 13
    Last Post: 2007-02-09, 04:52
  3. Sip 3rd Edition beta sdk
    By eob123 in forum Symbian
    Replies: 1
    Last Post: 2005-12-02, 16:52
  4. Problem with SIP Plug-in for Series 60 SDK 2.0
    By jalakuri in forum Symbian Tools & SDKs
    Replies: 27
    Last Post: 2005-08-22, 09:55
  5. SIP Plugin Memory Leak
    By relliott98 in forum Symbian Tools & SDKs
    Replies: 6
    Last Post: 2005-04-21, 16:14

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×