I am a Lead Support Specialist for SMF. Because our forum system has built-in wireless support (WAP, WAP2 and i-mode compatible), I sometimes browse the boards from my Nokia 3100 phone.

However, with the most recent version of the forum system (1.1RC1), I noticed that I was no longer able to post messages (new topics, replies or sending PMs) from my phone. Everytime I tried to post something, I either got sent back to the board index (if I was sending a PM or trying to start a new topic) or back to the first page of the topic (if I was trying to reply to a topic). Because the forum system sends you back to the board index if it doesn't understand the query string (usually when you enter an invalid "action" value), I decided to look at the URL of the page I was being sent to when the form was posted to see if I could figure out what was going on. When I looked at it, I figured out that my phone was sticking "x-up-destcharset=4" at the front of the query string.

Normally this wouldn't be a problem, but we seperate our query string parameters with a ; instead of an & (because it looks nicer). When you post something, there are usually several parameters in the query string, and since the x-up-destcharset wasn't an expected parameter, it gets seperated from the rest of the query string with an & instead of a semicolon, causing the forum system to see the "action" parameter as everything else in the query string instead of seeing several additional parameters.

What exactly is this x-up-destcharset parameter? Is this something that the forum system should pay attention to, or is it something that we can safely ignore and strip from the query string? I tried searching Google for answers, but most of the sites were in Japanese and the rest weren't any help.