×

Discussion Board

Results 1 to 5 of 5
  1. #1
    Registered User
    Join Date
    Dec 2005
    Posts
    8

    Exclamation Audio uplink problem.. 7610

    Hi...

    playing a file during audio uplink ..

    iMdaAudioRecorderUtility = CMdaAudioRecorderUtility::NewL(*this, NULL, 80,EMdaPriorityPreferenceTimeAndQuality);

    i set the above method , it plays well in speaker but when i mute the speaker its not able to uplink , i think its a known issue with lot of posts ,but still couldn't solve the problem i'm using seires 60 /7.0 ,and device 7610, 6630.

    can u suggest me where its wrong ....
    Thankx
    SymPC.

  2. #2
    Nokia Developer Moderator
    Join Date
    Mar 2003
    Location
    Lempäälä/Finland
    Posts
    29,169

    Re: Audio uplink problem.. 7610

    How do you mute thye speaker ?

    yucca

  3. #3
    Registered User
    Join Date
    Dec 2005
    Posts
    8

    Exclamation Re: Audio uplink problem.. 7610

    Hi.. thankx for reply

    by following way i used to mute the speaker .
    //by RPhone.
    const TInt KDeviceSpeakerSet = 10059;


    TInt volume = 0;
    TPtr8 ptr(REINTERPRET_CAST(TText8*, &volume), sizeof(volume),sizeof(volume));
    Set(KDeviceSpeakerSet, ptr);
    Last edited by SymPC; 2005-12-13 at 04:56.

  4. #4
    Nokia Developer Moderator
    Join Date
    Mar 2003
    Location
    Lempäälä/Finland
    Posts
    29,169

    Re: Audio uplink problem.. 7610

    never seen it done that way, anyway, if that sets the volume to zero, and when knowing that the output target selection with the API is broken, I would assume that it also sets the Uplink volume to zero as well.

    yucca

  5. #5
    Registered User
    Join Date
    Dec 2005
    Posts
    8

    Exclamation Re: Audio uplink problem.. 7610

    Hi...

    But i can hear they sound of surrounding ,but i can't hear any sound played by player ,its not set to zero ...
    any suggestions

Similar Threads

  1. audio file play problem
    By himsymbian in forum Symbian Media (Closed)
    Replies: 1
    Last Post: 2008-03-14, 06:48
  2. Problem regarding Nokia 6630 Audio....
    By skumar_rao in forum Mobile Java General
    Replies: 4
    Last Post: 2007-07-09, 10:00
  3. nokia 6630 audio problem
    By aditya.raut in forum Mobile Java General
    Replies: 0
    Last Post: 2005-06-15, 09:17
  4. audio streaming problem
    By nitinp_bioinf in forum Symbian
    Replies: 2
    Last Post: 2004-10-04, 11:05
  5. Please help : problem installing Nokia Audio Suite 1.0.1
    By marexb in forum Mobile Java Tools & SDKs
    Replies: 4
    Last Post: 2003-12-25, 14:32

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×