×

Discussion Board

Results 1 to 3 of 3
  1. #1
    Registered User
    Join Date
    Sep 2005
    Posts
    2

    I encounter one strange problem,Any advices are welcome.

    When I compile my project: myproject.
    I get an error PRJ0019: A tool returned an error code from "Performing Pre-Build Event..."


    I found there are always some "\\" in the path.
    I already check all setting in my project properties.Now there is no "\\"in my project properties. however I still can't remove this problem.

    Any advices are welcome.

    The following are my error output. I highlight the "\\" with color.

    epocroot = \Symbian\8.0a\S60_2nd_FP2\
    * C:\Symbian\8.0a\S60_2nd_FP2\\epoc32\tools\cshlpcmp.bat C:\Projects\myproject\help\myproject.cshlp
    ........
    * Copying C:\Projects\myproject\help\myproject.hlp to C:\Symbian\8.0a\S60_2nd_FP2\\Epoc32\wins\c\system\myproject\\myproject.hlp

    ........
    ERROR: RCMake failed: Failed to copy C:\Projects\myproject\help\myproject.hlp to C:\Symbian\8.0a\S60_2nd_FP2\\Epoc32\wins\c\system\help\myproject.hlp: java.io.FileNotFoundException: ...
    Project : error PRJ0019: A tool returned an error code from "Performing Pre-Build Event..."

  2. #2
    Registered User
    Join Date
    Sep 2005
    Posts
    2

    Re: I encounter one strange problem,Any advices are welcome.

    I resolved this problem by disable the option"compile help " of Carbide.
    In fact, this is my second time encounter the problem raised by the Carbide.

  3. #3
    Super Contributor
    Join Date
    Sep 2004
    Posts
    1,048

    Re: I encounter one strange problem,Any advices are welcome.

    Hi,

    Your issue probably depends on a discrepancy between the cshelp definition and the assumption of the cshelp build process.

    The build process for cshelp in Carbide.vs assumes that the created help file is called <project>.hlp. This however also must be defined in the .cshlp file. In the .cshlp file you should find a section something like:

    ...
    <files>
    <source><file>Symbian8.rtf</file></source>
    <destination>Symbian8.hlp</destination>
    </files>
    ...

    Make sure that the destination is defined as <project>.hlp, in your case myproject.hlp. After this the help file should build correctly.

Similar Threads

  1. VERY strange memory full problem..
    By etamburini in forum Mobile Java General
    Replies: 9
    Last Post: 2005-05-17, 15:50
  2. Strange MIDlet slowdown when use GameCanvas instead Canvas
    By alexey_kr in forum Mobile Java General
    Replies: 1
    Last Post: 2005-05-06, 15:26
  3. Strange thing with active objects(KRequestPending?)
    By carl_rocha in forum Symbian Networking & Messaging (Closed)
    Replies: 0
    Last Post: 2004-05-25, 14:33
  4. Wav sound strange problem on 7650
    By FatalError in forum Mobile Java Media (Graphics & Sounds)
    Replies: 3
    Last Post: 2003-08-04, 15:12
  5. Strange problem with nokia 3510 and mms
    By paspau in forum General Messaging
    Replies: 1
    Last Post: 2002-09-02, 07:35

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •