×

Discussion Board

Results 1 to 5 of 5
  1. #1
    Registered User
    Join Date
    Oct 2003
    Posts
    120

    Unhappy HELP ME OUT !!! URGENT

    Hi all,

    I just got my https connection working perfectly on my emulator but unable to run the same on my mobile devcie. I have created a ".keystore" file and configured it in my tomcat server and then exported the certificate (.cer) from the same keystore and then imported that certificate into my toolkit and everything went well for Emulator.

    But real probelms starts here

    When planned to testing the same midlet from my mobile device i am unable to get any certiifcate poping on mobile device and app throwing ioexception.

    please can anyone help me out how to import the certificate on to my mobile device when a java application(midlet) makes a https request internally.

    or did i do something wrong in the any configuration. please help me out my application is hanging out for this issue. i am using SONY ERICSSON Z1010

    THANKS IN ADVANCE

  2. #2
    Super Contributor
    Join Date
    Mar 2003
    Location
    Finland
    Posts
    9,569

    Re: HELP ME OUT !!! URGENT

    Well, for a Sony Ericsson Z1010 related issue you should probably try asking on a Sony Ericsson discussion/support board, and not a Nokia site.

    So, try http://developer.sonyericsson.com

  3. #3
    Registered User
    Join Date
    Oct 2003
    Posts
    120

    Unhappy Re: HELP ME OUT !!! URGENT

    Hi Petrib,

    But just now i got my Nokia 6630 and tried the same application but still no sucess and i was getting an IO Exception as Nativer Error - 36.

    and when i trying to browse a simple html page on my web server via https from mobile i unable to open the page.

    Please help me out.Is that anything else i need to enable on the mobile device to activate the https protocol for device.

    Thanks in ADVANCE.

  4. #4
    Super Contributor
    Join Date
    Mar 2005
    Location
    Paris
    Posts
    814

    Re: HELP ME OUT !!! URGENT

    in symbian, -36 is :

    KErrDisconnected -36 "Disconnected"

  5. #5
    Registered User
    Join Date
    Oct 2003
    Posts
    120

    Re: HELP ME OUT !!! URGENT

    hi njzk2,

    so what does this indicate,any server side issues or probelm with my app .

    But one more mile stone what i achevied is that the application is running on frineds mobile which internally inturn connecting to my IP ,but he is out side my country.(he stays in INDIA).

    Can anyone let me know does i need to enable any special settings form telco side to make https connection.

Similar Threads

  1. 6630 and Http -- Nokia PLEASE HELP ME -- URGENT URGENT!!!!
    By earamsey in forum Mobile Java General
    Replies: 1
    Last Post: 2005-12-02, 17:06
  2. Urgent Symbian Developer Opportunities!!!
    By SymbEmployer in forum Symbian User Interface
    Replies: 0
    Last Post: 2004-02-12, 12:37
  3. Urgent Symbian Developer Opportunities!!!
    By SymbEmployer in forum Symbian
    Replies: 0
    Last Post: 2004-02-12, 12:35
  4. Very very urgent !!!
    By carlover in forum General Messaging
    Replies: 1
    Last Post: 2003-06-09, 17:23
  5. Need help compiling - Urgent!!!
    By tianlye in forum Symbian
    Replies: 2
    Last Post: 2003-03-31, 09:25

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×