×

Discussion Board

Results 1 to 5 of 5

Hybrid View

  1. #1
    Registered User
    Join Date
    Dec 2005
    Posts
    2

    SDK compatibility

    Hi,

    I downloaded an evaluation version of Codewarriror for Symbian v3.1. I am also using a SDK for Nokia 6630 phone: 2nd edition, feature pack 2.

    I started to make a simple hello world application. It runs fine on the simulator. But when I download it on the phone, it doesn t appear on the screen. It is impossible to find it. I read the forum and saw that a lot of people have the same problem. It is usually related to a wrong UID number. I changed it carrefully and tried to have it working but without any success. All the things I tried where not working.

    Finally, one question comes to my mind: Is this SDK compatible with CDW for Symbian 3.1 ?

    Regards

    Matthieu

  2. #2
    Registered User
    Join Date
    Dec 2005
    Posts
    2

    Re: SDK compatibility

    I will try to give more details :

    If you go to this page http://www.forum.nokia.com/main/1,,1_74_1,00.html
    you ll see that Code Warrior for Symbian v3.1 supports the Series 60 SDK for 2nd and 3rd Editions.

    But, if you go this web page http://www.forum.nokia.com/info/sw.n...ac61a0ae6.html
    You ll see on the PDF that the 2nd edition feature pack 2 is not supported by codewarrior v3.1.

    What is the correct statement ?
    How to evaluate the tools with a Nokia 6630 phone ?

    Regards,

    Matthieu Vendeville

  3. #3
    Registered User
    Join Date
    Aug 2004
    Posts
    1

    Re: SDK compatibility

    Did you create a console application or UI application?

    Thanks

  4. #4
    Registered User
    Join Date
    May 2005
    Posts
    30

    Re: SDK compatibility

    Quote Originally Posted by smus
    Did you create a console application or UI application?

    Thanks
    this problem may be kust likne mine. I use CW 3.1 pro and compile its example "HelloWorldBasic" into EXE. It will work as expect on emulator. But when it comes to real device(for example, we now are using NOKIA 3250). It simplly not running at all. I can't either get any wrong message, or get any view on screen. I seem not run at all.

  5. #5
    Registered User
    Join Date
    Feb 2005
    Posts
    48

    Re: SDK compatibility

    Here are couple of things that you need to remember.

    - When you are using 2nd edition the application extension must be .app
    - With 3rd edition the extension is .exe

    So please check from your application .pkg file that everything is correctly set. You can also use TRK on target debugging tool to ensure the functionality of your application on the phone (with TRK you do not need .pkg file).

Similar Threads

  1. issue with vc.net compatibility of third edition beta SDK
    By sameet in forum Symbian Tools & SDKs
    Replies: 2
    Last Post: 2005-11-11, 10:37
  2. sdk 2.1 to sdk 3.0 compatibility
    By veciofio in forum PC Suite API and PC Connectivity SDK
    Replies: 2
    Last Post: 2003-11-25, 21:55
  3. Series 60 Concept Emulator (SDK Beta 0.2 Linux) not working
    By mattbee in forum Mobile Java Tools & SDKs
    Replies: 1
    Last Post: 2003-06-10, 11:43
  4. Series 60Series 60 MIDP Concept SDK Beta 0.2 Linux bug?
    By kauppi in forum Mobile Java Tools & SDKs
    Replies: 3
    Last Post: 2003-04-07, 09:05
  5. Http connection problem in 6310i
    By teahola in forum Mobile Java General
    Replies: 1
    Last Post: 2002-10-03, 18:46

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •