×

Discussion Board

Results 1 to 9 of 9
  1. #1
    Regular Contributor
    Join Date
    May 2005
    Location
    Brasov, Romania
    Posts
    431

    S60 3rd capabilities problem?

    Hello!

    I'm currently porting an application from S60 2nd to S60 3rd. I made all the changes needed for the application to comply with the new "guidelines" (i.e. code compiling on GCCE, data caging etc.) but I am having a problem when I try to run the application on device.

    The installation works fine, but when I try to start the application I get a Menu: System error (-20) after a few seconds, without the possibility to see even the first screen.

    The only capability I set for the application was ReadUserData. The fact is that I also write some file contents (but not at the start of the application), but the files are located in resource\apps\myApp, where they say I have the right to write my own data (and also the path of the resources that CEikonEnv::Static()->EikAppUi()->Application()->ResourceFileName() is returning).

    The other problem is that I use a dll that I could not copy with the installer but I managed to copy it manually in the sys\bin folder.

    From what I've seen, the main generally allowed capabilities for a developer certificate includes ReadUserData, WriteUserData, ReadDeviceData, WriteDeviceData (I doubt the last is allowed since I get a "Application access not granted" when I install the sis).

    So, the main problem would be the capabilities that I should declare and the paths that are allowed to my application to write any file during run.

    Can anyone give me a clue?

    Thank you!

  2. #2
    Nokia Developer Champion
    Join Date
    Jul 2004
    Posts
    2,015

    Re: S60 3rd capabilities problem?

    You should investigate why you can't install the dll with the installer - if the installer won't install it then there will be a reason for that, maybe it has the same name or SID as an already installed DLL for example.

  3. #3
    Registered User
    Join Date
    Jun 2004
    Posts
    25

    Re: S60 3rd capabilities problem?

    I get the same error "Menu: System error (-20)" when trying to launch my application, also ported from older Series60, capabilities are those that can be used when self signing (NetworkServices LocalServices ReadUserData WriteUserData UserEnvironment).
    I also has a dll that is installed in the sis, but for me the installation works. Emulator works, installation works, but when trying to launch application this error is the only thing that pops up.

    -20, could it be KErrCorrupt? From e32err.h:
    System wide error code - indicates that some media is not formatted properly,
    or links between sections of it have been corrupted.
    Could it be that application is linked against some library that does not have a corresponding dll on the device? Like etel3rdparty.dll in the old days..
    I have tried on both N80 and N71 with the same error...

  4. #4
    Registered User
    Join Date
    Jan 2005
    Posts
    12

    Re: S60 3rd capabilities problem?

    Did you find a solution to the problem? I also get the Menu: System Error (-20) when trying to start the application. The application is linked against my own dll that is copied to the \sys\bin folder. When I don't link the dll the application starts without problems.

  5. #5
    Regular Contributor
    Join Date
    May 2003
    Posts
    96

    Re: S60 3rd capabilities problem?

    Sorry, NOT A SOLUTION.

    I have exactly the same problem
    I can install properly DLL and GUI separately (2 sisx files).
    But when I start the application I get : Menu: system error (-20)!
    (It works properly in emulator).

    Some details, hoping that someone could see the reason.
    1. the GUI works if I exclude loading and using of DLL.

    2. GUI & DLL have both CAPABILITY NONE

    3. GUI libraries (in mmp file):
    LIBRARY euser.lib apparc.lib cone.lib eikcore.lib avkon.lib commonengine.lib efsrv.lib estor.lib MYLIB.lib

    4. DLL libraries in mmp
    LIBRARY euser.lib estlib.lib apparc.lib cone.lib eikcore.lib efile.lib efsrv.lib c32.lib

    5. MYLIB is using EPOCALLOWDLLDATA (.mmp)

    6. the only file in MYLIB.pkg is
    "C:\Symbian\9.1\S60_3rd_MR_4\EPOC32\RELEASE\GCCE\UDEB\MYLIB.dll" -"!:\sys\bin\MYLIB.dll"
    (I’ve tried even GCCE\UREL)

    7. Remote debugging doesn’t start (Unspecified general OS-related error) on the while it works for the GUI without DLL.

    Am I missing something?
    Mik

  6. #6
    Registered User
    Join Date
    Apr 2003
    Location
    Sofia, Bulgaria
    Posts
    23

    Re: S60 3rd capabilities problem?

    Incorrect DSO files exported by the IDE cause the problem (GCCE DLL builds + KErrCorrupt).

    The solution is to build your DLLs from the command line:

    bldmake bldfiles
    abld build gcce urel

    Once the correct DSO is exported you can compile the other modules using IDE or command line.

    Hope this helps.

    Regards,
    Tony

  7. #7
    Registered User
    Join Date
    Aug 2006
    Posts
    1

    Re: S60 3rd capabilities problem?

    Hello,

    I had typed a longer reply but there was a problem with the site >_<

    So I'll keep it short this time:
    manually destroy ALL files generated when compiling your project inside the SDK (and not only in epoc32/BUILD).

    Tell me if it works for you!

  8. #8
    Super Contributor
    Join Date
    Mar 2004
    Location
    Czech Republic
    Posts
    2,037

    Re: S60 3rd capabilities problem?

    Hi guys

    1/ I had the same problem - when I build everything on command line it starts working...
    2/ I had no idea why it cannot be built from IDE? Did you found the reason why .dso files produced by IDE are malformed?
    3/ Should I made builds for target only from command line?

    I'm using 3rd MR SDK.

    Regards,
    STeN

  9. #9
    Regular Contributor
    Join Date
    Mar 2003
    Posts
    50

    Re: S60 3rd capabilities problem?

    TonyStoyanov: it indeed helps, thanks encountered this issue for the first time myself, and wasted the better half of the day pulling my hair.

    is this CodeWarrior related or how come I havent seen it before? ponder..

    - Matti
    --
    Matti Dahlbom
    http://irssibot.777-team.org/

Similar Threads

  1. problem about S60 Emulator
    By robin_zj in forum Mobile Java Tools & SDKs
    Replies: 2
    Last Post: 2006-02-16, 23:23
  2. Carbide.vs & S60 3rd edition Beta problem
    By alias133 in forum Mobile Java Tools & SDKs
    Replies: 2
    Last Post: 2005-11-14, 04:59
  3. problem in C++ Series 60 3rd Ed. SDK for Symbian OS (Beta)
    By jagdeep_nokia in forum Symbian Tools & SDKs
    Replies: 9
    Last Post: 2005-10-28, 10:08
  4. problem with "sendas" example in s60 SDK
    By deepakrvce in forum Symbian Tools & SDKs
    Replies: 0
    Last Post: 2005-03-02, 06:24
  5. Problem with ChoiceEements On S60
    By ritec31 in forum Mobile Java General
    Replies: 0
    Last Post: 2004-04-20, 16:20

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×