×

Discussion Board

Results 1 to 2 of 2
  1. #1
    Registered User
    Join Date
    Jan 2006
    Posts
    1

    xhtml: Pls help

    Hi

    I am not sure if this is correct forum to post my query. Since i could not get a correct forum thought to post my query here. Please help me..!!

    I have a dobt. Hope some one will clear my doubts in this forum.

    I am using IE 6.0 to browse some plain html pages. Now i have convered this simple html(test.html) to XHTML by adding <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01//EN" "http://www.w3.org/TR/html4/strict.dtd"> in the beginning of the html.

    Now..after adding the above doctype tag, i removed some closed tags ,((</td></td>) and quotes from attributes to see if i get an error since the code which i used is not as per standard xhtml! But..my html renders perfectly.

    My question is why i am not getting any error inspite of using improper tags and coding style.
    does IE 6 ignores <!doctype> and renders the page as usual.?

    please help me on this

    thanks
    Last edited by nokia_06; 2006-01-09 at 07:35.

  2. #2
    Registered User
    Join Date
    Jun 2004
    Location
    HEL
    Posts
    36

    Re: xhtml: Pls help

    Hi,

    First off, you DTD is actually for HTML4. The strict DTD for XHTML 1 is
    Code:
    <!DOCTYPE html
    PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN"
    "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">
    IE doesn't support XHTML properly. If you do things properly, you should be sending XHTML as application/xhtml+xml. To serve this correctly, you should also include the <?xml...?> declaration too. If you do this, and you browse the page in IE, it will try to download it.

    Get yourself a decent browser that support application/xhtml+xml. Firefox is just one. Note that if you do send content as application/xhtml+xml and you deliberately or otherwise write non-conformant code, the page will break
    Cheers,

    Jamie

    # Any form of employment is strictly prohibited ......

Similar Threads

  1. S80 Platform SDK and Visual Studio .NET Linking Error
    By jayantjain in forum Mobile Java Tools & SDKs
    Replies: 1
    Last Post: 2005-10-07, 22:14
  2. code warrior problems
    By mayankkedia in forum Carbide.c++ IDE and plug-ins (Closed)
    Replies: 2
    Last Post: 2004-10-25, 06:59
  3. problem with codewarrior 5.2
    By mayankkedia in forum Symbian Tools & SDKs
    Replies: 3
    Last Post: 2004-09-27, 16:08
  4. Cannot compile SDK's examples for 7650 platform...
    By midletsoft in forum Symbian Tools & SDKs
    Replies: 2
    Last Post: 2003-08-12, 19:11

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×