×

Discussion Board

Results 1 to 2 of 2
  1. #1
    Registered User
    Join Date
    Aug 2004
    Posts
    4

    Angry Beta 3 install problems

    Hi there!

    I have literally re-installed everything from scratch 4 times, and still get the same problem - what am I doing wrong here?

    1) Setup s60-3.0-cpp-rb.3.6.2.zip
    1b) Install the toolchain from the installed package via start -> programs
    1c) Set the path environment variable to point to the <toolchain>\bin
    2) Extract the shipped example files (from the s60-3.0-cpp-rb.3.6.2.zip file)
    3) As per doc, go to helloworldbasic\group directory
    4) Run bldmake bldfiles - this bitches about the RVCT compiler version
    5) abld build - produces lots of output and errors
    6) Try to start epoc, get following error: "Failed to execute the emulator <path to epoc.exe"
    7) When I start epoc.exe manually, the app is not installed in the emulator (the docs say it should be under applications).

    My first attempt was with Code Warrior, but apart from running in the emulator, I could never compile to ARM5 due to RVCT compiler version errors - no help, no documentation, I tried to change the target compiler, but then all the commandline options are incorrect for gcc.

    Short of throwing my laptop against the wall, is there anything else I can try?

    I am busy downloading 2nd FP3 (I suppose I was putting too much faith into the beta version?). Maybe if I install 2 and then 3 on top of it things will work better?

    Any help will be *greatly* appreciated!

    Thanks,
    Andi

  2. #2
    Registered User
    Join Date
    Oct 2003
    Posts
    13

    Re: Beta 3 install problems

    Don't worry about RVCT warnings, that's normal behavior. You shouldn't build for armv5 if you don't have RVCT compiler. Instead, you should build for gcce target. You should be able to start emulator from command line by typing just "epoc". Type "devices" and check if you have the default SDK set correctly.

    Final SDK is coming soon.

Similar Threads

  1. Install serie 60 sdk, problems
    By miriamgs in forum Mobile Java Tools & SDKs
    Replies: 1
    Last Post: 2005-12-20, 04:43
  2. Series 60 Concept Emulator (SDK Beta 0.2 Linux) not working
    By mattbee in forum Mobile Java Tools & SDKs
    Replies: 1
    Last Post: 2003-06-10, 11:43
  3. Series 60Series 60 MIDP Concept SDK Beta 0.2 Linux bug?
    By kauppi in forum Mobile Java Tools & SDKs
    Replies: 3
    Last Post: 2003-04-07, 09:05
  4. Problems with Nokia Series 60 MIDP SDK Beta 0.1
    By TobiAlex in forum Mobile Java Tools & SDKs
    Replies: 0
    Last Post: 2002-08-27, 14:37
  5. NDS Beta 0.2 or 0.3 + HP notebook = nothing but problems
    By mturu70 in forum Mobile Java General
    Replies: 0
    Last Post: 2002-06-03, 11:36

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×