Discussion Board

Results 1 to 3 of 3
  1. #1
    Registered User
    Join Date
    Jan 2006
    Posts
    7

    Deployment problem

    Hi All and Petrib,
    I had created an Application(in cbuilder) and am able to run it successfully with the emulator. I changed the option to ARMI with urel option and generated the sis file and deployed the same to nokia 6600. The application gets installed without any problem. When I try to open the application through Application Browser in the device the application is not listed along with the other applications, but the application is listed in the Application Manager. Is there any setting available in cbuilder so that the application gets listed along with the other application(so that I can run the application)?
    Thanks in Advance
    Srinivas

  2. #2
    Nokia Developer Expert
    Join Date
    Jun 2005
    Posts
    923

    Re: Deployment problem

    Are you copying all the necessary files in your .pkg file specification? Make sure the .aif, .app and .rsc files are in-place and being copied to the right folders on the device.

    Daniel

  3. #3
    Registered User
    Join Date
    Jan 2006
    Posts
    7

    Re: Deployment problem

    hi daniel,
    Thanks for the reply,
    This is the content of my .pkg file:

    HTML Code:
    ;
    ; Installation file for PhoneBkEx application
    ;
    ;Languages
    &EN
    ;
    ; UID is the app's UID
    ;
    #{"PhoneBk Ex"},(0x101F612E),1,0,0
    ;
    ;Supports Series 60 v 0.9
    ;This line indicates that this installation is for the Series 60 platform v0.9
    ;This line must appear _exactly_ as shown below in the sis file
    ;If this line is missing or incorrect, the sis file will not be able
    ;to be installed on Series 60 v0.9 platforms
    (0x101F6F88), 0, 0, 0, {"Series60ProductID"}
    ;
    ; Four files to install
    ;
    "\Symbian\Series60_1_2_B\epoc32\release\winsb\udeb\z\system\apps\PhoneBkEx\PhoneBkEx.app"-"!:\system\apps\PhoneBkEx\PhoneBkEx.app"
    "\Symbian\Series60_1_2_B\epoc32\release\winsb\udeb\z\system\apps\PhoneBkEx\PhoneBkEx.rsc"-"!:\system\apps\PhoneBkEx\PhoneBkEx.rsc"
    "\Symbian\Series60_1_2_B\epoc32\release\winsb\udeb\z\system\apps\PhoneBkEx\PhoneBkEx_caption.rsc"-"!:\system\apps\PhoneBkEx\PhoneBkEx_caption.rsc"
    "\Symbian\Series60_1_2_B\epoc32\release\winsb\udeb\z\system\apps\PhoneBkEx\PhoneBkEx.aif"-"!:\system\apps\PhoneBkEx\PhoneBkEx.aif"
    
    ; end of pkg file
    this is the content of my C:\Symbian\Series60_1_2_B\epoc32\release\winsb\udeb\z\system\Apps\PHONEBKEX directory:

    HTML Code:
    <DIR>          .
    <DIR>          ..
             1,944 PHONEBKEX.AIF
            35,328 PHONEBKEX.APP
                68 PHONEBKEX.def
             1,941 PHONEBKEX.RSC
         1,703,936 PHONEBKEX.tds
                52 PHONEBKEX_CAPTION.RSC
    Thanks in Advance
    Srinivas

Similar Threads

  1. J2ME: Problem in Nokia Solution for a software problem
    By mte01 in forum Mobile Java Tools & SDKs
    Replies: 4
    Last Post: 2011-06-08, 05:52
  2. problem when stop playing video on 3650 and try to play again
    By niko86 in forum Mobile Java General
    Replies: 5
    Last Post: 2007-08-03, 07:40
  3. Ringing problem with Nokia N70
    By DVogdos in forum Audio
    Replies: 2
    Last Post: 2007-06-26, 20:49
  4. Problem with eglSwapBuffers and heap corruption
    By greatape in forum Symbian Media (Closed)
    Replies: 2
    Last Post: 2007-05-24, 03:35
  5. J2ME: Problem in Nokia Solution for a media problem
    By mte01 in forum Mobile Java Tools & SDKs
    Replies: 0
    Last Post: 2005-08-12, 11:30

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×