×

Discussion Board

Results 1 to 12 of 12
  1. #1
    Registered User
    Join Date
    Mar 2003
    Posts
    4

    Post Carbide.vs and 3rd

    Carbide.vs hasn't been updated to support the non-beta of the s60 3rd edition SDK, so I've been trying to get it to work myself...

    Make sure you have installed the latest 3rd Ed SDK, then install Carbide.vs 2.0. Copy the file

    \Program Files\Common Files\SYMBIAN\SDK Descriptors\Nokia\S60_3rd_Beta_v2.xml

    to

    \Program Files\Common Files\SYMBIAN\SDK Descriptors\Nokia\S60_3rd_v2.xml

    Edit the file, and change the stuff at the top to:

    Code:
    <?xml version="1.0" encoding="utf-8"?>
    <sdk version="2.0" supplier="Nokia" revision="1.0" author="Nokia" xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" >
    	<description shortName="S60 3.0" deviceId="S60_3rd" configName="S60_30"
    	  platformUid="0x101F7961" platformIdentification="Series60ProductID" defaultPlatform="WINSCW"
    	  deviceName="com.nokia.s60" projectType="Symbian9.S60">
    	  Series 60 SDK version 3.0
    	</description>
    You can now import the project and select the final 3rd Ed SDK. The only problem seems to be with compiling the resources, for example:

    "C:\\Symbian\\9.1\\S60_3rd\\S60Ex\\OpenGLEx\\SimpleCube\\data\\simplecube_reg.rss(31): error: Warning: (047) the STRUCT that this resource is based on contains a STRUCT[] data member which has not been used in this resource, the missing element is: 'datatype_list'"

    Anybody want to take over from here?

  2. #2
    Registered User
    Join Date
    Mar 2003
    Posts
    4

    Re: Carbide.vs and 3rd

    Seems to be just a "treat warnings as errors" thing, I can build and debug the samples fine, openGL finally too!

  3. #3
    Registered User
    Join Date
    Oct 2004
    Posts
    20

    Re: Carbide.vs and 3rd

    hmm.. tried it, didnt work for me. i can import and build with lot of errors in avkon.hrh though
    Last edited by jamespoh; 2006-01-24 at 03:50.

  4. #4
    Registered User
    Join Date
    Jan 2006
    Posts
    22

    Re: Carbide.vs and 3rd

    Dear Sir
    sir, does Series 80 Platform 2.0 SDK for Symbian OS for codewarrior IDE be supported by carbide vs??? , if not, connecting a mobile device to a computer and accessing their files is my project and is it sulitable to work on codewarrior or Visual C++???
    Pl reply Sir
    Thanks
    jan

  5. #5
    Registered User
    Join Date
    Oct 2004
    Posts
    20

    Re: Carbide.vs and 3rd

    think carbide supports most previous nokia versions. i am not sure what you are trying to do with the accessing of files though..since there is already a cable and nokia pc suite(not sure of the name)? to access the files, or u have the extremely useful explorer tools ard. i think its from symbianyucca? sorry if i have offended anyone if i got it wrong.

  6. #6
    Registered User
    Join Date
    Jan 2006
    Posts
    22

    Re: Carbide.vs and 3rd

    hello
    actually i didnt explain properly. am doing a project on remote desktop access on mobile dvice. ineed to bring the whole desktop on the screen and access the files. this is done by installing vnc servers in the pcs and trying to connect the vnc server and the mobile device, so i was searching for an sdk for this project and IDE. so i was just aking if coding is simpler in codewarrior or carbide vs as am new to both.
    thanks
    jan

  7. #7
    Registered User
    Join Date
    Oct 2004
    Posts
    20

    Re: Carbide.vs and 3rd

    hmm...coding shld be the same, u still code in the same language anyway. Personally i prefer .net can access all my project files visuall without clicking too much. But then again, i am not very familiar with codewarrior.

    Anyway, carbide is just a 'plug-in'. u still need to install ur s80/s60 SDKs on top of ur IDE. U only really need carbide if u have to code using the latest s60 3rd ed SDK. But carbide makes things alot easier for previous versions as well.

    Requirement: IDE+Perl+Java+Carbide + Symbian SDKs

  8. #8
    Registered User
    Join Date
    Jan 2006
    Posts
    8

    Re: Carbide.vs and 3rd

    plz from where i can download the Carbide.vs 2.0 version?
    any can send the link

  9. #9
    Registered User
    Join Date
    Jan 2006
    Posts
    4

    Question Re: Carbide.vs and 3rd

    Quote Originally Posted by kpoole
    Seems to be just a "treat warnings as errors" thing, I can build and debug the samples fine, openGL finally too!
    Hi kpoole,
    I am also facing carbide.vs and 3rd edition problem. Can you tell how u were able to build and debug the programs.
    Thanks,

  10. #10
    Registered User
    Join Date
    Jan 2006
    Posts
    22

    Lightbulb Re: Carbide.vs and 3rd

    Dear Sir
    my sdk is Series 80 Platform 2.0 SDK for Symbian OS , doesn this sdk have an ide itself??? can i use the carbide plug in for this platform?

    IDE + Perl+Java+Carbide + Symbian SDKs
    Last edited by jan_s15; 2006-01-28 at 09:38.

  11. #11
    Regular Contributor
    Join Date
    Nov 2005
    Posts
    67

    Re: Carbide.vs and 3rd

    It seems to me that 3rd SDK does not work with Carbide.vs (2.0).

    Mean while waiting a new s60 development tools ( Eclipse/Carbide.c++ ) start to study S60 development from scratch.

    Study to build everything by hand work ( like notepad ).

    This way you are quaranteed to navigate from one tool family to another tool family in near future.

    Nokia is not a IDE company that makes money producing software tools like Microsoft.

  12. #12
    Registered User
    Join Date
    Mar 2003
    Location
    Gyor
    Posts
    236

    Re: Carbide.vs and 3rd

    I install pretty much everything with VS C++ .net & Carbide only the S60 1.x, S80 1.x & 7710 SDK left out. My SDK configuration manager look like:

    S60 SDK 3.0 Beta
    S60 SDK 3.0 Alpha (as kpoole wrote before manual copy+modify otherwise SDK not selectable in configurator) - Errors related STRUCT[] -sometimes comment out avkon.rh and use avkon.hrh instead will elimate them
    S60 2nd FP2 .net (6630)
    S80 v2.0 DP2 .net (9500)
    S60 2nd FP3 .net (N90)
    S60 v2.0 .net (6600)

    Yes, My c:\Symbian directory over 2G :)

    The Cleaner Service

Similar Threads

  1. OpenGL ES on S60 3rd Edition SDK Emulator
    By specjones in forum Symbian Tools & SDKs
    Replies: 7
    Last Post: 2008-09-30, 10:22
  2. Network Problem in 3rd Ed. Emulator
    By twlai in forum Symbian Tools & SDKs
    Replies: 1
    Last Post: 2007-01-31, 15:11
  3. TTime : TInt64& Int64() problem in S60 3rd edition
    By iulian_moldovan in forum Symbian Tools & SDKs
    Replies: 3
    Last Post: 2006-01-24, 13:07
  4. Carbide.vs & S60 3rd edition Beta problem
    By alias133 in forum Mobile Java Tools & SDKs
    Replies: 2
    Last Post: 2005-11-14, 04:59
  5. Symbian v8.1?? 3rd platforma?
    By stenlik in forum Symbian Networking & Messaging (Closed)
    Replies: 2
    Last Post: 2005-09-05, 09:49

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •