×

Discussion Board

Results 1 to 1 of 1
  1. #1
    Regular Contributor
    Join Date
    Sep 2005
    Posts
    138

    Problems with setDiscoverable(DiscoveryAgent.GIAC)

    Hello:

    When I try to set my MIDlet in discoverable mode I have some problems:

    if (!miLocalDevice.setDiscoverable(DiscoveryAgent.GIAC)) {

    throw new IOException("Error bla bla bla...");
    }

    If I execute my midlet, it "deep freeze" my emulator. Debuggin the application I've seen that is in this line, and it crashes the debugger too! (Deep freezed again) why? In my phone (6630) nothing happens. :? :? :? but I can't see if all its ok.

    In j2me.org said me that perhaps I must "activate" the "discoverable mode" manually in a menu in the emulator, but I don't know how to do this. I'm using the "Nokia_Prototype_SDK_4_0" Any idea?

    Thank you!!!
    Last edited by Pepper_91; 2006-01-30 at 08:44.

Similar Threads

  1. NGage devkit problems
    By cambion in forum Symbian
    Replies: 3
    Last Post: 2004-12-07, 07:50
  2. Usability problems still need fixing. Can we help nokia?
    By Trial in forum General Development Questions
    Replies: 3
    Last Post: 2004-02-26, 15:05
  3. problems with app on Nokia 6600
    By Java-Developer in forum Mobile Java General
    Replies: 6
    Last Post: 2004-02-16, 13:49
  4. Problems with Nokia carkit CK-1W
    By Batunas in forum General Development Questions
    Replies: 1
    Last Post: 2004-02-09, 18:18
  5. Problems installing Nokia developers suite with JBuilder 8 Personal
    By maaberge in forum Mobile Java Tools & SDKs
    Replies: 0
    Last Post: 2003-04-05, 00:42

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×