×

Discussion Board

Results 1 to 5 of 5
  1. #1
    Registered User
    Join Date
    Feb 2006
    Posts
    2

    SIP Profile enabling problem

    Hi,

    I have problem when I am trying to enable SIP profile.

    I have SDK S60 2nd FP3 and Nokia_SIP_Plug-in_4[1].0_for_Series_60_CW.zip.

    When I am trying to enable SIP profile;

    iProfileRegistry->EnableL( *iProfile, *this )

    It leaves with code -17808. If I trap it and continue, I can register to
    SIP server. But when the registration is completed, I try to generate invite
    request;

    iInvite = CSIPInviteDialogAssoc::NewL( *iConnection, to, *iProfile );

    It leaves with code -17717 (EInvalidRegistrationState).

    Any ideas?

    Steps what I do are;

    1. Create CSIP
    2. Create CSIPProfileRegistry
    3. Get default profile
    4. Enable profile (Leaves with code -17808)
    5. Call CSIPProfileRegistry::ConnectionL
    6. Wait for call to IncomingResponse( CSIPClientTransaction&,
    CSIPRegistration& aRegistration )
    7. Create CSIPInviteDialogAssoc (Leaves with code -17717)

    Same leave (-17808) occurs also when I try to register using ChipFlip.

    - JP

  2. #2
    Registered User
    Join Date
    Feb 2006
    Posts
    2

    Re: SIP Profile enabling problem

    Additional question;

    How to create SIP profiles in SDK 3rd ed.?

    - JP

  3. #3
    Registered User
    Join Date
    Dec 2005
    Posts
    10

    Re: SIP Profile enabling problem

    Hi,

    just had the same error code (-17808) and found out that it was because of wrong settings in the SIP Profile. That is, username or password or whatever is setup wrong!

    Grtzz
    Paul.

  4. #4
    Super Contributor
    Join Date
    Oct 2005
    Posts
    739

    Re: SIP Profile enabling problem

    Hi,
    try emulating it in two machines in a network.
    It may work.try the same if you get the error as -191
    Cheers
    Priju

  5. #5
    Regular Contributor
    Join Date
    Jun 2005
    Location
    Philippines
    Posts
    163

    Wink Re: SIP Profile enabling problem

    Quote Originally Posted by klakmoes
    Hi,

    just had the same error code (-17808) and found out that it was because of wrong settings in the SIP Profile. That is, username or password or whatever is setup wrong!

    Grtzz
    Paul.
    Just make sure you have all the fields filled up when you access your SIP profile from within the emulator window. Aside from the Registrar's or Proxy's IP address, the service profile, and the default access point, it can be anything other than blank. To test, you can try the Chipflip example from SIP v3.

Similar Threads

  1. Problem Running JSR 180 SIP Example !!!
    By sujoydas in forum Mobile Java General
    Replies: 3
    Last Post: 2008-04-27, 13:16
  2. Profile Switch Problem for N70
    By mateen_maldar in forum Symbian User Interface
    Replies: 4
    Last Post: 2006-10-12, 08:01
  3. Sip 3rd Edition beta sdk
    By eob123 in forum Symbian C++
    Replies: 1
    Last Post: 2005-12-02, 16:52
  4. Series 60 SIP Programmer's Guide 問題
    By wgarnett in forum Symbian
    Replies: 5
    Last Post: 2005-09-09, 13:13
  5. Problem with installing Sip Testing program
    By isravoicer in forum Symbian Tools & SDKs
    Replies: 0
    Last Post: 2004-08-21, 16:00

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •