×

Discussion Board

Results 1 to 3 of 3
  1. #1
    Registered User
    Join Date
    Feb 2006
    Posts
    15

    How to debug console application with CW3.1 and 3rd edition ?

    Hi all,

    I have tried to Debug console application with CW 3.1. SDK and emulator is S60 3rd edition 1.0. I have choosed debug from CW menus and emulator start but console application will not start.

    If I start my application double clicking from release/udeb/myapp.exe , epoc emulator works fine and also my console application.

    If I debug UI Application which is in the grid I can start debugging when choose debug for CW and I start application from grid when emulator is started.

    Problem is that debug command not start the application automatic. How I can start .exe which is not in the Application Grid?

    -rdparty

  2. #2
    Registered User
    Join Date
    Jun 2003
    Posts
    20

    Re: How to debug console application with CW3.1 and 3rd edition ?

    In CodeWarrior IDE, in project properties, set the debug target to winscw/release/udeb/eshell.exe and once its command line session launches, enter the application name you wish to debug an hit enter.
    Your application should be starting and good to go with debug.

    Alternatively, just set the debug target directly to application .exe you build. This may sometimes have side effect of emulator going to S60 menu grid after your console app just launches.

  3. #3
    Registered User
    Join Date
    Oct 2004
    Posts
    89

    Re: How to debug console application with CW3.1 and 3rd edition ?

    Hi 3rdparty


    In the CW IDE i was not able to find any options like "project properties".
    Can you let me know , in which of the menu its available or how can i reach there.

    Your feedback will be greatly appreciated.

    phalder

Similar Threads

  1. Launching an application in SDK 3rd edition
    By sdalis in forum Symbian
    Replies: 2
    Last Post: 2006-05-15, 13:19
  2. How to debug console application with CW3.1 and 3rd edition ?
    By 3rdparty in forum Mobile Java Tools & SDKs
    Replies: 0
    Last Post: 2006-02-01, 17:40
  3. TTime : TInt64& Int64() problem in S60 3rd edition
    By iulian_moldovan in forum Symbian Tools & SDKs
    Replies: 3
    Last Post: 2006-01-24, 13:07
  4. S60 3rd Edition - Can't Debug in .NET 2003
    By twlai in forum Symbian Tools & SDKs
    Replies: 6
    Last Post: 2006-01-10, 10:04
  5. OpenGL ES Support in S60 3rd Edition Beta SDK
    By choefele in forum Symbian Media (Closed)
    Replies: 2
    Last Post: 2005-12-14, 06:01

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×