×

Discussion Board

Results 1 to 6 of 6
  1. #1
    Registered User
    Join Date
    Dec 2005
    Posts
    7

    Error linking example EComPlugin

    I'm trying to compile the eCom plugin provided as part of the ChipFlip example in SIPPlugin 4.0 (ChipFlipEComPlugin) in the following environment:

    - Visual Studio .NET 2003
    - Carbide 2.0
    - SDK S60_2nd_FP3

    The plugin is a ECOMII type dll.

    When I build the plugin using debug configuration for FP3 (Deb_S60_23_WINSCW) I get the following error message.

    Error in linking: Object reference not set to an instance of an object.
    MyApplicationEComPlugin : error PRJ0003 : Error spawning 'link.exe'.

    If I try building for SP2 Deb_S60_23_WINSCW everything works.

    Any idea?

    Thanks

  2. #2
    Super Contributor
    Join Date
    Sep 2004
    Posts
    1,048

    Re: Error linking example EComPlugin

    Hi,

    ECOMII is not a supported target type for Carbide.vs 2.0. When you imported the project there was (or at least should have been) a message that the target type is not supported and that the project most likely will not build (as unsupported targets are simply imported as dll's).

    Unfortunately the list of supported types got lost when doing the docs.

  3. #3
    Registered User
    Join Date
    Dec 2005
    Posts
    7

    Re: Error linking example EComPlugin

    thanks, now I know I can't use VS to compile ECOMIIC.

    So I tried to compile from the command line.
    Unfortunately I can successfully compile for S60_2nd_FP2, but I can't for FP3.

    When I run "abld build winscw udeb", I get the following error message:

    "ERROR: Unable to identify a valid CodeWarrior for Symbian OS installation"

    After that, the directory tree that usually gets built under $(SDK_ROOT)/Epoc32/BUILD/.../MYAPPLICATIONECOMPLUGIN/GROUP during the compilation process fails to be created and make exits with "No such file or directory" error message.

    Can anyone help with that?

    Thanks a lot

  4. #4
    Registered User
    Join Date
    May 2005
    Posts
    30

    Re: Error linking example EComPlugin

    Try running:
    "C:\Nokia\Tools\Carbide_vs\WINSCW\bin\env_update.exe"
    and chose the second option, the restart your computer.

    It updates your environment to find the codewarrior compiler executable, but be careful, sometimes it messes up the environment and it gets too big, then epoc tools complain about EPOCROOT not being capitalized. Then you need to open a shell with a bigger environment size, e.g. cmd /E:4096

    good luck,

    Dominik

  5. #5
    Registered User
    Join Date
    Dec 2005
    Posts
    7

    Re: Error linking example EComPlugin

    I tried what you suggested and it didn't work.
    I launched env_update and picked the second option (compiler version 3.2.x) and then epoc tools actually complain about EPOCROOT not being capitalized.
    I started a command prompt with "command /E:32768" (cmd does not support /E switch) but epoc tools still complain.

    any more ideas?

    Thanks

  6. #6
    Registered User
    Join Date
    May 2005
    Posts
    30

    Re: Error linking example EComPlugin

    we had this problem too, so far only a very dirty workaround did the job:
    add in line 30
    $found = 1;
    to Epoc32\tools\e32env.pm to stop the script from dying.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×