×

Discussion Board

Results 1 to 4 of 4
  1. #1
    Registered User
    Join Date
    Feb 2006
    Posts
    2

    VS2003+Carbide2.0 .rls files trouble

    Hello. I'm imorting project with localization to VS using carbide 2.0. During build process I've got following error:

    C:\\MySymbianApps\\ControlPanelApp\\ControlPanelApplication.rls(5): error: syntax error
    RCOMP failed with code 1
    ERROR: RCMake failed: (Resources): rcomp.exe failed with code 1. (Reason: Incorrect function.)
    Project : error PRJ0019: A tool returned an error code from "Performing Pre-Build Event..."

    Could you please advise something to relolve this issue. In CW 3.1 all works fine. I'm using SDK for s60 fp1 and S60 fp3.
    Thank you

  2. #2
    Super Contributor
    Join Date
    Sep 2004
    Posts
    1,048

    Re: VS2003+Carbide2.0 .rls files trouble

    Well, the error message indicates that there is a syntax error on line 5 in the file ControlPanelApplication.rls. Without seeing what the file contents is, it is quite hard to guess what the problem might be.

  3. #3
    Registered User
    Join Date
    Feb 2006
    Posts
    2

    Re: VS2003+Carbide2.0 .rls files trouble

    //
    // Copyright (c) 2004 Symbian Ltd. All rights reserved.
    //

    rls_string STRING_r_appslist_page "Applications List"

    As far as I can judge compiler doesn't understand "rls_string"

  4. #4
    Super Contributor
    Join Date
    Sep 2004
    Posts
    1,048

    Re: VS2003+Carbide2.0 .rls files trouble

    Strange.. Is there a reason why you could not use a .loc file and #define in stead?

    - rename file to ControlPanelApplication.loc
    - replace the rls_string.. with "#define STRING_r_appslist_page "Applications List" etc?

Similar Threads

  1. trouble sending audio files 6630
    By rcooksey in forum Audio
    Replies: 7
    Last Post: 2005-10-28, 13:55
  2. trouble with audio files
    By rcooksey in forum Bluetooth Technology
    Replies: 0
    Last Post: 2005-10-03, 14:32
  3. AMR files from WebServer
    By pjericoh in forum Audio
    Replies: 0
    Last Post: 2005-05-10, 21:31
  4. Sending several files without using SIS
    By stopin in forum Symbian
    Replies: 0
    Last Post: 2003-07-10, 16:32
  5. Trouble Downloading SP-Midi Files with a Nokia 7650 through our WAP site
    By CyberShark in forum Digital Rights Management & Content Downloading
    Replies: 1
    Last Post: 2003-02-18, 14:59

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×