×

Discussion Board

Results 1 to 12 of 12
  1. #1
    Registered User
    Join Date
    Feb 2006
    Posts
    2

    New s60v3 SDK (07.02.06) is corrupted?!?

    Hi!

    Can any one tell me what's going on with new s60 SDK? First release, dated 21.01.06 works pretty well, but now it seems SDK has been silently updated, and probably now it is broken.

    Here is some tech details:
    - While trying to compile for emulator (winscw target), "Can't locate warnings.pm in @INC" error message is appers
    - While trying to compile for device (gcce target), "make: missing separator" error is appears.

    Regards,
    Oleg.

    Edit: sorry, winscw problem has been solved by installing updated perl, but gcce target still won't work... :(
    Last edited by Olegator99; 2006-02-13 at 07:44.

  2. #2
    Registered User
    Join Date
    Jun 2003
    Posts
    20

    Re: New s60v3 SDK (07.02.06) is corrupted?!?

    Please specify what commands you run to build GCCE variant, how many SDKs you have and where they are installed. Also, where did you install GCCE itself and which Perl version you are using. Hint: SDK Release Note contains important info, including on versions and known issues, it may help to look at it.
    Last edited by msmyslov; 2006-02-15 at 19:51.

  3. #3
    Registered User
    Join Date
    Jan 2006
    Posts
    12

    Re: New s60v3 SDK (07.02.06) is corrupted?!?

    I'm facing almost the same problem.

    has previosly installed sdk ... and compilable project.
    Now I updated within new sdk available on nokia forum site.
    I can compile project for winscw, but for gcce it throws error:
    "Can't locate warnings.pm in @INC"

    Working sdk size: 274.740.513 bytes downloaded from forum nokia site: 26.01.2006
    Bugious sdk size: 274.740.025 bytes downloaded from forum nokia site: 10.04.2006

    both of them has in releaseNotes.txt:
    RELEASE NOTE FOR S60 3RD EDITION SDK FOR SYMBIAN OS, FOR C++ 18.01.2006

  4. #4
    Registered User
    Join Date
    May 2006
    Posts
    6

    Re: New s60v3 SDK (07.02.06) is corrupted?!?

    Same problem also here. This is what I appears if i try to build the helloworld example:
    Code:
    C:\Symbian\9.1\S60_3rd\S60Ex\helloworldbasic\group>abld build gcce udeb
      make -r  -f "\Symbian\9.1\S60_3rd\EPOC32\BUILD\Symbian\9.1\S60_3rd\S60Ex\hello
    worldbasic\group\EXPORT.make" EXPORT VERBOSE=-s
    make: Nothing to be done for `EXPORT'.
      make -r  -f "\Symbian\9.1\S60_3rd\EPOC32\BUILD\Symbian\9.1\S60_3rd\S60Ex\hello
    worldbasic\group\GCCE.make" MAKEFILE VERBOSE=-s
    make -s  -C \Symbian\9.1\S60_3rd\S60Ex\helloworldbasic\group -f "ICONS_SCALABLE_
    DC.MK" TO_ROOT=..\..\..\..\..\.. EPOCBLD=..\..\..\..\..\..\Symbian\9.1\S60_3rd\E
    POC32\BUILD\Symbian\9.1\S60_3rd\S60Ex\helloworldbasic\group\ICONS_SCALABLE_DC\GC
    CE TO_BLDINF=..\..\..\..\..\..\Symbian\9.1\S60_3rd\S60Ex\helloworldbasic\group P
    LATFORM=GCCE MAKMAKE
    perl -S makmake.pl  -D \Symbian\9.1\S60_3rd\S60Ex\helloworldbasic\group\HELLOWOR
    LDBASIC GCCE
    WARNING: Cannot determine the version of the RVCT Compiler.
      make -r  -f "\Symbian\9.1\S60_3rd\EPOC32\BUILD\Symbian\9.1\S60_3rd\S60Ex\hello
    worldbasic\group\GCCE.make" LIBRARY VERBOSE=-s
    make -s  -C \Symbian\9.1\S60_3rd\S60Ex\helloworldbasic\group -f "ICONS_SCALABLE_
    DC.MK" TO_ROOT=..\..\..\..\..\.. EPOCBLD=..\..\..\..\..\..\Symbian\9.1\S60_3rd\E
    POC32\BUILD\Symbian\9.1\S60_3rd\S60Ex\helloworldbasic\group\ICONS_SCALABLE_DC\GC
    CE TO_BLDINF=..\..\..\..\..\..\Symbian\9.1\S60_3rd\S60Ex\helloworldbasic\group P
    LATFORM=GCCE LIB
    make -s  -r -f "\Symbian\9.1\S60_3rd\EPOC32\BUILD\Symbian\9.1\S60_3rd\S60Ex\hell
    oworldbasic\group\HELLOWORLDBASIC\GCCE\HELLOWORLDBASIC.GCCE" LIBRARY
    \Symbian\9.1\S60_3rd\EPOC32\BUILD\Symbian\9.1\S60_3rd\S60Ex\helloworldbasic\grou
    p\HELLOWORLDBASIC\GCCE\HELLOWORLDBASIC.GCCE:76: *** missing separator.  Stop.
    make: *** [LIBRARYHELLOWORLDBASIC] Error 2
      make -r  -f "\Symbian\9.1\S60_3rd\EPOC32\BUILD\Symbian\9.1\S60_3rd\S60Ex\hello
    worldbasic\group\GCCE.make" RESOURCE CFG=UDEB VERBOSE=-s
    make -s  -C \Symbian\9.1\S60_3rd\S60Ex\helloworldbasic\group -f "ICONS_SCALABLE_
    DC.MK" TO_ROOT=..\..\..\..\..\.. EPOCBLD=..\..\..\..\..\..\Symbian\9.1\S60_3rd\E
    POC32\BUILD\Symbian\9.1\S60_3rd\S60Ex\helloworldbasic\group\ICONS_SCALABLE_DC\GC
    CE TO_BLDINF=..\..\..\..\..\..\Symbian\9.1\S60_3rd\S60Ex\helloworldbasic\group P
    LATFORM=GCCE CFG=UDEB RESOURCE
    Checking: ..\gfx\qgn_menu_helloworldbasic.svg
    Choosing...
    Loading mif icons...
    Loading file: ..\gfx\qgn_menu_helloworldbasic.svg
    Writing mif: \Symbian\9.1\S60_3rd\epoc32\data\z\resource\apps\helloworldbasic_ai
    f.mif
    make -s  -r -f "\Symbian\9.1\S60_3rd\EPOC32\BUILD\Symbian\9.1\S60_3rd\S60Ex\hell
    oworldbasic\group\HELLOWORLDBASIC\GCCE\HELLOWORLDBASIC.GCCE" RESOURCEUDEB
    \Symbian\9.1\S60_3rd\EPOC32\BUILD\Symbian\9.1\S60_3rd\S60Ex\helloworldbasic\grou
    p\HELLOWORLDBASIC\GCCE\HELLOWORLDBASIC.GCCE:76: *** missing separator.  Stop.
    make: *** [RESOURCEHELLOWORLDBASIC] Error 2
      make -r  -f "\Symbian\9.1\S60_3rd\EPOC32\BUILD\Symbian\9.1\S60_3rd\S60Ex\hello
    worldbasic\group\GCCE.make" TARGET CFG=UDEB VERBOSE=-s
    make -s  -C \Symbian\9.1\S60_3rd\S60Ex\helloworldbasic\group -f "ICONS_SCALABLE_
    DC.MK" TO_ROOT=..\..\..\..\..\.. EPOCBLD=..\..\..\..\..\..\Symbian\9.1\S60_3rd\E
    POC32\BUILD\Symbian\9.1\S60_3rd\S60Ex\helloworldbasic\group\ICONS_SCALABLE_DC\GC
    CE TO_BLDINF=..\..\..\..\..\..\Symbian\9.1\S60_3rd\S60Ex\helloworldbasic\group P
    LATFORM=GCCE CFG=UDEB BLD
    make -s  -r -f "\Symbian\9.1\S60_3rd\EPOC32\BUILD\Symbian\9.1\S60_3rd\S60Ex\hell
    oworldbasic\group\HELLOWORLDBASIC\GCCE\HELLOWORLDBASIC.GCCE" UDEB
    \Symbian\9.1\S60_3rd\EPOC32\BUILD\Symbian\9.1\S60_3rd\S60Ex\helloworldbasic\grou
    p\HELLOWORLDBASIC\GCCE\HELLOWORLDBASIC.GCCE:76: *** missing separator.  Stop.
    make: *** [TARGETHELLOWORLDBASIC] Error 2
      make -r  -f "\Symbian\9.1\S60_3rd\EPOC32\BUILD\Symbian\9.1\S60_3rd\S60Ex\hello
    worldbasic\group\GCCE.make" FINAL CFG=UDEB VERBOSE=-s
    make -s  -C \Symbian\9.1\S60_3rd\S60Ex\helloworldbasic\group -f "ICONS_SCALABLE_
    DC.MK" TO_ROOT=..\..\..\..\..\.. EPOCBLD=..\..\..\..\..\..\Symbian\9.1\S60_3rd\E
    POC32\BUILD\Symbian\9.1\S60_3rd\S60Ex\helloworldbasic\group\ICONS_SCALABLE_DC\GC
    CE TO_BLDINF=..\..\..\..\..\..\Symbian\9.1\S60_3rd\S60Ex\helloworldbasic\group P
    LATFORM=GCCE CFG=UDEB FINAL
    
    C:\Symbian\9.1\S60_3rd\S60Ex\helloworldbasic\group>
    I use the versions of gcce and perl which are part of the S60 3rd Edition SDK, so there shouldn't be any problems.

    This is the content of HELLOWORLDBASIC.GCCE at the corresponding lines:
    Code:
    74: ifndef CC_INSTALL_PATH
    75: 	CC_INSTALL_PATH=operable program or batch file.
    76: \..
    77: 	STATIC_LIBS = $(STATIC_LIBS_PATH)"$(CC_INSTALL_PATH)\arm-none-symbianelf\lib" $(STATIC_LIBS_PATH)"$(CC_INSTALL_PATH)\lib\gcc\arm-none-symbianelf\3.4.3"
    78: endif
    Changes to these lines are without effect, because this file will be regenerated by abld. Any clues?

    Cheers,

    Timo

  5. #5
    Registered User
    Join Date
    Nov 2003
    Posts
    30

    Re: New s60v3 SDK (07.02.06) is corrupted?!?

    Hello,
    Just include the ACL ARM toolchain path in the PATH env. variable ( C:\Program Files\CSL Arm Toolchain\bin).
    It worked for me!

    Jesus

  6. #6
    Registered User
    Join Date
    May 2006
    Posts
    6

    Re: New s60v3 SDK (07.02.06) is corrupted?!?

    Thanks! That was the problem!

    Cheers,

    Timo

  7. #7
    Registered User
    Join Date
    Aug 2007
    Posts
    25

    Re: New s60v3 SDK (07.02.06) is corrupted?!?

    what do you mean of "ACL ARM toolchain" , is it included int the s60 SDK ?

  8. #8
    Super Contributor
    Join Date
    Mar 2004
    Location
    Singapore
    Posts
    9,968

    Re: New s60v3 SDK (07.02.06) is corrupted?!?

    That means "ACL ARM toolchain" Comes Free with SDK v3.x Download and in the Process of installation installer asks you to Install OR not.

  9. #9
    Registered User
    Join Date
    May 2007
    Location
    Chennai
    Posts
    15

    Re: New s60v3 SDK (07.02.06) is corrupted?!?

    Hi,

    "make -s -r -f "\Symbian\9.1\S60_3rd_MR\EPOC32\BUILD\3rd\cs.series60-3rd\expat-1
    .95.8\Symbian\EXPAT\GCCE\EXPAT.GCCE" LIBRARY
    \Symbian\9.1\S60_3rd_MR\EPOC32\BUILD\3rd\application\expat-1.95.8\Symbian\EX
    PAT\GCCE\EXPAT.GCCE:76: *** missing separator. Stop.
    make: *** [LIBRARYEXPAT] Error 2"

    Its an open source library called Expat.lib. In my application S60 3rd edition it creates the lib in WINSCW mode. But in GCCE UREL mode it throws those erros. I dont know whats the problem..

    Waiting for reply soon...
    Jayaseelan.V
    Dhanus Technologies.,-INDIA.

  10. #10
    Registered User
    Join Date
    Jan 2008
    Posts
    6

    Re: New s60v3 SDK (07.02.06) is corrupted?!?

    I have installed SDK or XP and Vista. Everything works fine on XP but on Vista I get the same error. I have toolchain in my path (See Path env variable below):

    C:\Symbian\9.1\S60_3rd_MR_2\S60Ex\helloworldbasic\group>path
    PATH=C:\Program Files\CSL Arm Toolchain\bin;C:\Program Files\Common Files\Symbian\Tools;C:\Perl\bin;C:\Program Files\PC
    Connectivity Solution\;C:\Windows\system32;C:\Windows;C:\Windows\System32\Wbem;

    C:\Symbian\9.1\S60_3rd_MR_2\S60Ex\helloworldbasic\group>arm-none-symbianelf-c++
    arm-none-symbianelf-c++: no input files

  11. #11
    Nokia Developer Moderator
    Join Date
    Oct 2006
    Location
    Finland
    Posts
    4,540

    Re: New s60v3 SDK (07.02.06) is corrupted?!?

    Quote Originally Posted by visual86 View Post
    I have installed SDK or XP and Vista. Everything works fine on XP but on Vista I get the same error. I have toolchain in my path (See Path env variable below):

    C:\Symbian\9.1\S60_3rd_MR_2\S60Ex\helloworldbasic\group>path
    PATH=C:\Program Files\CSL Arm Toolchain\bin;C:\Program Files\Common Files\Symbian\Tools;C:\Perl\bin;C:\Program Files\PC
    Connectivity Solution\;C:\Windows\system32;C:\Windows;C:\Windows\System32\Wbem;

    C:\Symbian\9.1\S60_3rd_MR_2\S60Ex\helloworldbasic\group>arm-none-symbianelf-c++
    arm-none-symbianelf-c++: no input files

    Have you checked the wiki on this one ? Check this

  12. #12
    Nokia Developer Moderator
    Join Date
    Oct 2006
    Location
    Finland
    Posts
    4,540

    Re: New s60v3 SDK (07.02.06) is corrupted?!?

    Note : Start a new thread for a new topic (Its unrelated to the discussion above)

    Edit : wanted to edit above post, but by mistake posted a new one :p

Similar Threads

  1. MIDP applicatyion accessing a servlet not working in series 60 emulator
    By ferozekadamapuzha in forum Mobile Java General
    Replies: 11
    Last Post: 2008-05-07, 18:04
  2. createImage on Nokia Series 40 MIDP Concept SDK Beta 0.3
    By GerardMason in forum Mobile Java Media (Graphics & Sounds)
    Replies: 2
    Last Post: 2003-09-30, 10:00
  3. Series 60 Concept Emulator (SDK Beta 0.2 Linux) not working
    By mattbee in forum Mobile Java Tools & SDKs
    Replies: 1
    Last Post: 2003-06-10, 11:43
  4. Series 60Series 60 MIDP Concept SDK Beta 0.2 Linux bug?
    By kauppi in forum Mobile Java Tools & SDKs
    Replies: 3
    Last Post: 2003-04-07, 09:05
  5. Http connection problem in 6310i
    By teahola in forum Mobile Java General
    Replies: 1
    Last Post: 2002-10-03, 18:46

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×