×

Discussion Board

Results 1 to 4 of 4
  1. #1
    Registered User
    Join Date
    Dec 2005
    Posts
    1,236

    Error Message: MMFControllerProxyServer4da8348 ViewSrv11

    Hi,
    I am developing a simple voice recording Application with Start and Stop functionality.
    When I am trying to call iMdaRecorderUtility->Stop() my application crashes with following popup message:
    ProgramClosed:
    MMFControllerProxyServer4da8348 ViewSrv11.

    Do anyone know anything about this.Please help.

    Regards,
    Sriky

  2. #2
    Nokia Developer Moderator
    Join Date
    Mar 2003
    Location
    Lempäälä/Finland
    Posts
    29,144

    Re: Error Message: MMFControllerProxyServer4da8348 ViewSrv11

    here's couple of docs about the topic:

    http://www3.symbian.com/faq.nsf/0/89...7?OpenDocument
    http://www3.symbian.com/faq.nsf/45ae...b?OpenDocument


    most often when I have seen this problem, it has been about calling cancel, and having docancel() or other cancel function that doesn't do cancellation right, thus makes the application AO system to hang.

    yucca

  3. #3
    Nokia Developer Moderator
    Join Date
    Feb 2006
    Location
    Budapest, Hungary
    Posts
    28,572

    Re: Error Message: MMFControllerProxyServer4da8348 ViewSrv11

    Hi, maybe it is not related to this issue, but CMdaAudioPlayerUtility also crashes your application, if you Stop() more than once per Play().

  4. #4
    Registered User
    Join Date
    Mar 2003
    Posts
    3

    Re: Error Message: MMFControllerProxyServer4da8348 ViewSrv11

    Hi All,

    We have also experienced the MMFControllerProxy ViewSrv 11 error in a S60 3rd edition handset with CMdaAudioPlayerUtility.

    What we are trying to do is to capture window server events and use CMdaAudioPlayerUtility to play some sounds when certain criterion is matched. However we sometimes get a ViewSrv 11 error when the player tries to play the sound. The approach we are currently using is to call Stop() if the player is playing sound and then call Play() to play the sound and this sometimes cause the error.

    Any insight is greatly appreciated. Thanks.

    Calvin

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •