×

Discussion Board

Results 1 to 5 of 5
  1. #1
    Registered User
    Join Date
    Jun 2005
    Posts
    8

    Unable to launch emulator : GCCE udeb

    Hi,

    I'm working with series 60 3rd (not the beta version, consequently I can't work with carbide) and Visual studio.net. But I've a big problem with GCCE.
    I'm doing those commands:
    bld make bldfiles
    abld build gcce udeb

    I've the following .exe files :
    Epoc32\release\GCCE\UDEB\HelloWorld.exe
    Epoc32\BUILD\HellowWorld\group\HELLOWORLD\GCCE\UDEB\Helloworld.exe

    But when I'm executing those files the emulator doesn't launch.
    If you have some suggestions thanks.

    Thanks

  2. #2
    Nokia Developer Moderator
    Join Date
    Feb 2006
    Location
    Budapest, Hungary
    Posts
    28,568

    Re: Unable to launch emulator : GCCE udeb

    ARM binaries do not run on Windows, use WINSCW.

  3. #3
    Registered User
    Join Date
    Jun 2005
    Posts
    8

    Re: Unable to launch emulator : GCCE udeb

    The problem with abld build winscw udeb is that I've got the following error :
    Unable to identify a valid codewarrior for symbian OS

    How can I do?
    Why does gcce mke a .exe in a udeb directory?



    Thanks

  4. #4
    Nokia Developer Expert
    Join Date
    Jan 2005
    Posts
    10

    Re: Unable to launch emulator : GCCE udeb

    For building WINSCW target, you need Nokia X86 compiler which comes with Codewarrior for Symbian OS product. You need to install atleast a personal edition to work build WINSCW target.

    The reason you have GCCE binaries in UDEB folder is because you build for UDEB target when you did abld build GCC udeb.

    For urel target, just specify urel instead of udeb.

  5. #5
    Registered User
    Join Date
    Jun 2005
    Posts
    8

    Re: Unable to launch emulator : GCCE udeb

    Carbide C++ has solved those problems!
    thanks

Similar Threads

  1. Launch J2ME App
    By sjb343 in forum Symbian
    Replies: 1
    Last Post: 2007-04-11, 08:24
  2. [newbie here] Link error
    By xitpu in forum Symbian
    Replies: 3
    Last Post: 2007-01-24, 16:53
  3. Unable to launch emulator : GCCE udeb
    By rem78 in forum Carbide.c++ IDE and plug-ins (Closed)
    Replies: 1
    Last Post: 2006-02-20, 16:20
  4. Replies: 3
    Last Post: 2005-10-12, 05:26
  5. Launch a file with parameters
    By j2k in forum Symbian
    Replies: 0
    Last Post: 2003-04-16, 22:58

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •