×

Discussion Board

Results 1 to 2 of 2
  1. #1
    Regular Contributor
    Join Date
    Mar 2003
    Location
    Rennes, France
    Posts
    50

    Building with another SDK in Carbide

    Hi,

    I'm trying to switch from codewarrior to carbide.

    Right now in CW, I have a project that I'm compiling with S60 SDK 2nd edition FP3. But then, I want to compile it for S60 SDK V3. So I just close the project and reimport the MMP file and specify the SDK I want to use.

    In carbide, I also have a project. Initially I specified only the S60 SDK 2nd edition FP3 in the build configuration. Then for some reason (e.g. I just installed a new SDK, and of course, that SDK is supported in Carbide), I want to compile it with another SDK (e.g. S60 SDK V3). How am I supposed to do that when that SDK doesn't appear in the "build configuration" view? Is there a way for reimporting the project and specify the SDK I want to use?

    Note:
    Of course, I don't have a MMP, because Carbide doesn't seem to generate one, so I can't use the option "Symbian MMP file" for reimporting

    -fred

  2. #2
    Super Contributor
    Join Date
    Sep 2004
    Posts
    1,048

    Re: Building with another SDK in Carbide

    Hi,

    In the current Carbide.c++ version you basically only get one shot at setting the target SDKs, either when you create or import a project (this will change in the future).

    However, there are things that you can do but these are not supported, so I would advise to use caution.

    If you later notice that you need a different SDK, you can "re"import the project in the following way (but make a backup copy of your project!)
    - Delete the project (but make sure you have the "Do not delete contents" option selected)
    - Do a new import of the project and select those SDKs that you need, the project will become "reincarnated" and should have all code changes that you have done (even if your .mpp is only partially correct, like the original .mmp that you used when you first imported). If you have created your project from a template you need to create some kind of .mmp file.

    Note however that the build setups for S60 2nd Ed and 3rd Ed are so different that you should really only choose one or the other for a project. The templates enforce this rule but importing you can select both 2nd ed and 3rd ed SDKs. However the set of files as well as file content for 2nd Ed and 3rd Ed are so different that it is difficult to maintain a project for both 2nd and 3rd.

Similar Threads

  1. Nokia S60 SDK and Carbide in VS.NET 6.0
    By MePHyst0 in forum Symbian Tools & SDKs
    Replies: 2
    Last Post: 2005-12-01, 20:46
  2. Series 60 Concept Emulator (SDK Beta 0.2 Linux) not working
    By mattbee in forum Mobile Java Tools & SDKs
    Replies: 1
    Last Post: 2003-06-10, 11:43
  3. Series 60Series 60 MIDP Concept SDK Beta 0.2 Linux bug?
    By kauppi in forum Mobile Java Tools & SDKs
    Replies: 3
    Last Post: 2003-04-07, 09:05
  4. Building a C++ application with Series 60 SDK
    By nadmeh in forum Symbian Tools & SDKs
    Replies: 0
    Last Post: 2002-12-25, 18:25
  5. Http connection problem in 6310i
    By teahola in forum Mobile Java General
    Replies: 1
    Last Post: 2002-10-03, 18:46

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×