×

Discussion Board

Results 1 to 1 of 1
  1. #1
    Registered User
    Join Date
    Mar 2006
    Posts
    1

    Unhappy All seems right, but no message is sent

    Hello,

    I'm new to SMS, and i've read some of the threads to start sending messages.
    Thought i knew it all, but when i send an SMS nothing happens. But the phone sends a 'OK' to all the AT commands i send, like this:

    Code:
    Me: 'AT' + Chr(13) + Chr(10)
    Phone: AT OK
    Me: ATZ + chr(13) + chr(10)
    Phone: ATZ  OK
    Me: 'AT+CMGF=0' + Chr(13) + Chr(10)
    Phone: AT+CMGF=0 OK
    Me: 'AT+CSMS=0' + chr(13) + chr(10)
    Phone: AT+CSMS=0 +CSMS: 1,1,1 OK
    Me: 'AT+CMGS=23' + chr(13) + chr(10)
    Phone:AT+CMGS=23 (this time no OK, but no ERROR also)
    Me: '0011000B915391191162320000AA0AE8329BFD4697D9EC37' + chr(26) + chr(13) + chr(10)
    Phone: 0011000B915391191162320000AA0AE8329BFD4697D9EC37 +CMGS:11 OK
    For this sample i thought that all is going well, but my phone do not send any message, and if i do it manually, i have no problem.

    What am i doing wrong?

    TIA,
    Joaquim
    Last edited by joaquimc; 2006-03-02 at 18:08.

Similar Threads

  1. Sending long message
    By njoandy1 in forum Smart Messaging
    Replies: 2
    Last Post: 2005-02-06, 09:38
  2. problem to send a service loading message push for 8310
    By alinesimon in forum General Messaging
    Replies: 1
    Last Post: 2002-05-06, 12:39
  3. Problem to send a service loading push message for 8310
    By alinesimon in forum General Messaging
    Replies: 1
    Last Post: 2002-05-06, 11:19
  4. Problem to send a service loadinfd push message for 8310
    By alinesimon in forum Smart Messaging
    Replies: 1
    Last Post: 2002-05-03, 10:49
  5. Doubt in Nokia PC Connrctivity SDK 2.1 demo (Visual basic).
    By narumugai in forum General Messaging
    Replies: 1
    Last Post: 1970-01-01, 02:00

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •