×

Discussion Board

Results 1 to 6 of 6
  1. #1
    Registered User
    Join Date
    Mar 2006
    Posts
    10

    Unhappy working on emulator but not on mobile

    Hi, I developed a "SocketConnection" client that is supposed to communicate with a PC Server over a GPRS connection, and send and recieve data.

    The problem is, the application is working on the emulator (send & recieve correctly) but when I run it on my Nokia 6600 it doesn't connect (there is no responce on the server or the client sides)

    Can some one help?

  2. #2
    Registered User
    Join Date
    Dec 2005
    Location
    Brazil
    Posts
    1,884

    Re: working on emulator but not on mobile

    Please explain, does it hang? Is there any exception or timeout?

    It is strange because Nokia 6600 is MIDP 2.0.

  3. #3
    Registered User
    Join Date
    Mar 2006
    Posts
    10

    Re: working on emulator but not on mobile

    Hi juarezjunior,

    When I run the application on my N6600 it runs, asks for GPRS connection, the "G" sign starts flashing, but after a (big) while it freezes!

    By the way, you may think my application has an error, but even ready examples by nokia or over IDE's fail, I dont know where is the fault!

  4. #4
    Registered User
    Join Date
    Feb 2006
    Posts
    12

    Re: working on emulator but not on mobile

    Hi Akaishi
    as you said about "G" connection is flashing for a long while then it is stable that means maybe your GPRS connection is not sutup correctly or error with your provoider

  5. #5
    Registered User
    Join Date
    Mar 2006
    Posts
    42

    Re: working on emulator but not on mobile

    Hay...this might be due to access point setting please change the Access point from wap to internet....u may contact ur service provider in this regard...they may inform u that what is the internet access point...Generally it is "internet" rather than "wap"...
    Muhammad Ummar Iqbal Bhutta
    Student (Computer Engineering)
    University of Engineering and Technology Lahore

  6. #6
    Registered User
    Join Date
    Mar 2006
    Posts
    10

    Re: working on emulator but not on mobile

    Hi everyone and thankx for the replies, I think I found what is the problem!

    My GPRS configurations are right
    But my ISP bans accessing websites with numiral IP addresses
    like: www.yahoo.com

    So when you try to connect to: 68.142.197.87 which is same as yahoo.com, you can't get connected and you are blocked

    However I have to verify this "theory"

Similar Threads

  1. sonify.org to focus on mobile device audio
    By hp3 in forum Mobile Java Media (Graphics & Sounds)
    Replies: 0
    Last Post: 2004-10-16, 16:39
  2. Nokia Mobile VPN Client
    By marcyl in forum Symbian Networking & Messaging (Closed)
    Replies: 1
    Last Post: 2003-12-01, 14:47
  3. MID files downloaded to the mobile are not working
    By jai_chinna in forum Nokia M2M
    Replies: 0
    Last Post: 2003-09-25, 17:34

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×