×

Discussion Board

Page 1 of 2 12 LastLast
Results 1 to 15 of 21
  1. #1
    Registered User
    Join Date
    Feb 2006
    Posts
    23

    S60-SDK3 not present in list of SDKs

    Hi,

    I am not able create Symbian project because "No SDKs were found".
    I have all wins sdk and I have S60 3.0 winscw SDK (S60-SDK-0548-3.0-f.3.215f).
    If I select Window->Preferences and Carbide.c++->SDK preferences I see all wins SDKs (and error text stating: No build configurations available for this SDK).
    This is expected since I do not have winscw SDK.

    Problem is why I do not see S60 3.0 on the list?
    I see following items:
    S607650
    S60FP3
    S80

    Click on "Rescan Now" does not help.

    Carbide.vs 2.0.1 has recognised S60 SDK 3.0. Since it does not support debuging using emulator I have to use Carbide.c++.

    Zdenko

  2. #2
    Nokia Developer Expert
    Join Date
    Oct 2004
    Location
    Austin, TX USA
    Posts
    271

    Re: S60-SDK3 not present in list of SDKs

    Can you please post your devices.xml file?

    Thanks,

    Matt P.

  3. #3
    Super Contributor
    Join Date
    Sep 2004
    Posts
    1,048

    Re: S60-SDK3 not present in list of SDKs

    Hi,

    Quote Originally Posted by Zdenko61
    Carbide.vs 2.0.1 has recognised S60 SDK 3.0. Since it does not support debuging using emulator I have to use Carbide.c++.
    Why do you say that Carbide.vs does not support emulator debug? It should. Do you have a problem or did you just not yet try it?

  4. #4
    Registered User
    Join Date
    May 2003
    Location
    Tropical Paradise Penang
    Posts
    43

    Re: S60-SDK3 not present in list of SDKs

    I'm having the same problem. I've installed S60_SDK3 but I can't create the S60 project becoz of "No SDK found"!

  5. #5
    Super Contributor
    Join Date
    Sep 2004
    Posts
    1,048

    Re: S60-SDK3 not present in list of SDKs

    Do you have English or non-English Windows installations?

  6. #6
    Registered User
    Join Date
    Feb 2006
    Posts
    23

    Re: S60-SDK3 not present in list of SDKs

    I have not tested debuging. When I select SDK in new project type, WINSCW is checked but WINS is not checked (since it is grey it is not possible to check it).
    My assumption was that debuging will not work in Visual Studio. I have tested it and it works.
    Thanks.

    BTW.
    Is there any reason yo use Carbide.c++ (Eclipse) instead of Carbide.vs (Visual studio)?

    Quote Originally Posted by mitts
    Hi,



    Why do you say that Carbide.vs does not support emulator debug? It should. Do you have a problem or did you just not yet try it?

  7. #7
    Registered User
    Join Date
    Feb 2006
    Posts
    23

    Re: S60-SDK3 not present in list of SDKs

    English SDK, English Windows XP
    Quote Originally Posted by mitts
    Do you have English or non-English Windows installations?

  8. #8
    Registered User
    Join Date
    Feb 2006
    Posts
    23

    Re: S60-SDK3 not present in list of SDKs

    I do not have devices.xml file in Carbide directory.
    I have found "lastKnownSDKList.xml" in Carbide\configuration\com.symbian.cdt.sdk directory.

    This is content of file:
    <?xml version="1.0" encoding="UTF-8"?><sdks><sdk buildConfig="unsupporetedSDK" enabled="true" epocRoot="C:\Symbian\6.1\Series60" id="S607650" isManuallyAdded="false" name="com.nokia.s60sym6"/><sdk buildConfig="unsupporetedSDK" enabled="true" epocRoot="C:\Symbian\8.1a\S60_2nd_FP3" id="S60FP3" isManuallyAdded="false" name="com.nokia.s60fp3"/><sdk buildConfig="unsupporetedSDK" enabled="true" epocRoot="C:\Symbian\7.0s\S80_DP2_0_SDK" id="S80" isManuallyAdded="false" name="com.nokia.s80"/></sdks>

    Quote Originally Posted by mpinsonneault
    Can you please post your devices.xml file?

    Thanks,

    Matt P.

  9. #9
    Super Contributor
    Join Date
    Sep 2004
    Posts
    1,048

    Re: S60-SDK3 not present in list of SDKs

    Zdenko61, Matt's question was related to Carbide.c++.

    There are a number of reason to use Carbide.vs as well as Carbide.c++.

    Carbide.c++ is the long term Nokia tools strategy so getting to know and use it certainly prepares you for where the Nokia/Symbian C++ tools are going. Expect to move to Carbide.c++ sooner or later for higher productivity and new features.

    Also if you use Eclipse for other things, Carbide will be a very good choice as skills for Symbian and your other work will nicely support each other. Carbide also has a build system for target building that is not based on the SDK and is very resilient + the debugger is very good for Symbian work.

    Carbide.vs is the good choice mainly if you use VS for other work. Also a few SDKs (such as the FP2 langauge kits for eg Chinese) are only supported on Carbide.vs as they are WINS SDKs.

  10. #10
    Nokia Developer Expert
    Join Date
    Oct 2004
    Location
    Austin, TX USA
    Posts
    271

    Re: S60-SDK3 not present in list of SDKs

    Zdenko61,

    The devices.xml file can probably be found in your Program Files\Common Files\Symbian folder.

    Regards,

    Matt P.

  11. #11
    Nokia Developer Expert
    Join Date
    Oct 2004
    Location
    Austin, TX USA
    Posts
    271

    Re: S60-SDK3 not present in list of SDKs

    bikerzon,

    Are you sure you have the CodeWarrior/WINSCW 3.0 SDK installed? That's the one that Carbide.c++ wants. If so, please post your devices.xml file from c:\program files\common files\symbian.

    Regards,

    Matt P.
    Last edited by mpinsonneault; 2006-03-10 at 20:51.

  12. #12
    Nokia Developer Expert
    Join Date
    Dec 2004
    Location
    Austin, TX
    Posts
    399

    Re: S60-SDK3 not present in list of SDKs

    Quote Originally Posted by Zdenko61
    I do not have devices.xml file in Carbide directory.
    I have found "lastKnownSDKList.xml" in Carbide\configuration\com.symbian.cdt.sdk directory.
    Hi Z - I can't tell if you either have installed S60 SDKs that we don't support (you should installl the versions for CodeWarrior/WINSCW) or you have modified your devices.xml after the install. For standard support of SDKs you should not modify your device entires for the SDKs that Carbide supports.

    Cheers,
    Tim

  13. #13
    Registered User
    Join Date
    Feb 2006
    Posts
    23

    Re: S60-SDK3 not present in list of SDKs

    I am talking about "S60 3rd Edition SDK for Symbian OS, for C++".
    When I go to S60 SDK download page there is ONLY ONE available SDK (English):
    (Text in combo)
    SDK for 3rd Edition (262 MB)

    Here is devices.xml
    <?xml version="1.0" encoding="UTF-8"?>
    <devices version="1.0">
    <device id="S60_3rd" name="com.nokia.s60" default="no" userdeletable="no">
    <epocroot>C:\Symbian\9.1\S60_3rd\</epocroot>
    </device>
    <device id="Series80_DP2_0_SDK_CW" name="com.nokia.Series80" default="no" userdeletable="no">
    <epocroot>c:\Symbian\7.0s\S80_DP2_0_SDK_CW\</epocroot>
    </device>
    <device id="Series80_DP2_0_SDK" name="com.nokia.Series80" default="yes" userdeletable="no">
    <epocroot>c:\Symbian\7.0s\S80_DP2_0_SDK</epocroot>
    </device>
    <device id="UIQ_21" name="com.symbian.UIQ" default="no" userdeletable="no">
    <epocroot>c:\Symbian\UIQ_21\</epocroot>
    </device>
    <device id="S60_2nd_FP3" name="com.nokia.series60" default="no" userdeletable="no">
    <epocroot>C:\Symbian\8.1a\S60_2nd_FP3\</epocroot>
    </device>
    </devices>

  14. #14
    Nokia Developer Expert
    Join Date
    Dec 2004
    Location
    Austin, TX
    Posts
    399

    Re: S60-SDK3 not present in list of SDKs

    Quote Originally Posted by Zdenko61
    Here is devices.xml
    <?xml version="1.0" encoding="UTF-8"?>
    <devices version="1.0">
    <device id="S60_3rd" name="com.nokia.s60" default="no" userdeletable="no">
    <epocroot>C:\Symbian\9.1\S60_3rd\</epocroot>
    </device>
    <device id="Series80_DP2_0_SDK_CW" name="com.nokia.Series80" default="no" userdeletable="no">
    <epocroot>c:\Symbian\7.0s\S80_DP2_0_SDK_CW\</epocroot>
    </device>
    <device id="Series80_DP2_0_SDK" name="com.nokia.Series80" default="yes" userdeletable="no">
    <epocroot>c:\Symbian\7.0s\S80_DP2_0_SDK</epocroot>
    </device>
    <device id="UIQ_21" name="com.symbian.UIQ" default="no" userdeletable="no">
    <epocroot>c:\Symbian\UIQ_21\</epocroot>
    </device>
    <device id="S60_2nd_FP3" name="com.nokia.series60" default="no" userdeletable="no">
    <epocroot>C:\Symbian\8.1a\S60_2nd_FP3\</epocroot>
    </device>
    </devices>
    Hi Zdenko - I cut and pasted your content into C:\Program Files\Common Files\Symbian\devices.xml

    then fired up Carbide.Express. When looking at the SDK Preferences they all show up with a Build Configuration listed for each SDK in the "SDK Information" text box.

    If you put your devices.xml in the location above do you still not see the SDKs listed in the SKD Preferences page?

    If you still have trouble pull down Window > Show View > Other > PDE Runtime > Error Log and see if there are any related errors there to give some diagnostics.

    Tim

  15. #15
    Registered User
    Join Date
    Feb 2006
    Posts
    23

    Re: S60-SDK3 not present in list of SDKs

    Hi Tim,

    Problem is solved.
    I have dual boot and two installations of XP (C: and F.
    VS, CarBide, Symbian SDKs are installed on both versions. Problem was when I was using Carbide from F: partition.
    Even system, VS and Carbide are on the F: partition, Carbide reads devices.xml from C: partition.
    Runing XP from first partititon interfered somehow.

    I have copied devices.xml from:
    F:\Program Files\Common Files\Symbian\
    to:
    C:\Program Files\Common Files\Symbian\
    and it works now.

    (I am sure that I posted devices.xml from C:\Program Files\Common Files\Symbian\, but it seems that I posted version from F:\Program Files\Common Files\Symbian\. No other logical explanation exists).

    Zdenko

Page 1 of 2 12 LastLast

Similar Threads

  1. FullCanvas to List bug S60
    By sohrabza in forum Mobile Java Media (Graphics & Sounds)
    Replies: 1
    Last Post: 2007-02-27, 16:05
  2. 6680 and bluetooth service profiles
    By ceruault in forum Mobile Java Networking & Messaging & Security
    Replies: 1
    Last Post: 2005-10-08, 22:24
  3. List class on S60 phones
    By sandie_quinn in forum Mobile Java General
    Replies: 3
    Last Post: 2003-08-29, 08:10
  4. Exclusive List behavior, S60
    By fmhunter in forum Mobile Java Tools & SDKs
    Replies: 1
    Last Post: 2002-11-08, 13:06
  5. S60 SDK bugs with List
    By xdimas in forum Mobile Java Tools & SDKs
    Replies: 0
    Last Post: 1970-01-01, 02:00

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •